Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1568911 - Bluetooth hci0: don't support firmware rome 0x1020200 since 4.15.14
Summary: Bluetooth hci0: don't support firmware rome 0x1020200 since 4.15.14
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1564888 1573036 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 12:15 UTC by M. Kristall
Modified: 2021-02-21 13:13 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 10:10:41 UTC
Type: Bug


Attachments (Terms of Use)

Description M. Kristall 2018-04-18 12:15:26 UTC
Description of problem:
Bluetooth does not work starting with kernel-4.15.14-300.fc27.x86_64

Version-Release number of selected component (if applicable):
4.15.14+

How reproducible:
Always

Steps to Reproduce:
Start with latest available kernel (currently kernel-4.15.17-300.fc27.x86_64)
Bluetooth no worky!

Start with kernel-4.15.13-300.fc27.x86_64
Bluetooth works!

Additional info:
$ lsusb | grep -i bluetooth
Bus 003 Device 002: ID 0cf3:3004 Qualcomm Atheros Communications AR3012 Bluetooth 4.0
$ dmesg | grep -i bluetooth
[    3.037438] usb 3-3: Product: Bluetooth USB Host Controller
[   27.858395] Bluetooth: Core ver 2.22
[   27.858427] Bluetooth: HCI device and connection manager initialized
[   27.858433] Bluetooth: HCI socket layer initialized
[   27.858436] Bluetooth: L2CAP socket layer initialized
[   27.858446] Bluetooth: SCO socket layer initialized
[   28.466248] Bluetooth: hci0: don't support firmware rome 0x1020200
[   37.735659] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   37.735660] Bluetooth: BNEP filters: protocol multicast
[   37.735665] Bluetooth: BNEP socket layer initialized

Comment 1 Hans de Goede 2018-04-18 12:29:51 UTC
Hmm, this is likely caused by this commit:

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit/?h=linux-4.15.y&id=7ec32f585fefd7c154453aa29ccf8fa2a11cc865

But I wonder if that means that that commit is wrong, or if something else is going on.

Can you try turning the machine off (instead of rebooting) and then directly boot into 4.15.17 ? And see if you still get the same error?

Comment 2 M. Kristall 2018-04-18 12:38:18 UTC
That is what I have been doing.

Comment 3 Hans de Goede 2018-04-18 13:20:27 UTC
(In reply to M. Kristall from comment #2)
> That is what I have been doing.

Ok, I've started a discussion upstream about this with you in the Cc.

Comment 4 nada81 2018-04-23 09:41:41 UTC
Hi, 
i have the same problem with my samsung notebook

Comment 5 Laura Abbott 2018-04-23 13:18:35 UTC
*** Bug 1564888 has been marked as a duplicate of this bug. ***

Comment 6 nada81 2018-04-25 11:50:16 UTC
how can we know if there are something new about that ? Thanks

Comment 7 Neyzan 2018-04-26 18:29:14 UTC
This was also reported in the Kernel's bugzilla (https://bugzilla.kernel.org/show_bug.cgi?id=199271) and I also reported it to the blueman-project (https://github.com/blueman-project/blueman/issues/862).

   Issue persists into kernel 4.15.17 and also after upgrading bluez to 5.49.3.

Reposting the below, for if they provide relevant info:


Debug output:

[root@192 ~]# blueman-applet --loglevel debug
blueman-applet version 2.1.alpha1 starting
blueman-applet 12.58.03 INFO     PluginManager:85 Load      : ['KillSwitch', 'NetUsage', 'ExitItem', 'PPPSupport', 'DhcpClient', 'StatusIcon', 'ShowConnected', 'AuthAgent', 'SerialManager', 'NMDUNSupport', 'DiscvManager', 'Networking', 'GameControllerWakelock', 'PowerManager', 'NMPANSupport', 'StandardItems', 'RecentConns', 'Menu', 'TransferService', 'DBusService']
blueman-applet 12.58.03 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.Menu.Menu'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.StatusIcon.StatusIcon'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.PowerManager.PowerManager'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.KillSwitch.KillSwitch'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.ExitItem.ExitItem'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.DBusService.DBusService'>
blueman-applet 12.58.04 WARNING  PluginManager:146 __load_plugin: Not loading PPPSupport because its conflict has higher priority
blueman-applet 12.58.04 WARNING  PluginManager:146 __load_plugin: Not loading DhcpClient because its conflict has higher priority
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.ShowConnected.ShowConnected'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.AuthAgent.AuthAgent'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.SerialManager.SerialManager'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.NMDUNSupport.NMDUNSupport'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.DiscvManager.DiscvManager'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.Networking.Networking'>
blueman-applet 12.58.04 INFO     Networking:31 load_nap_settings: Loading NAP settings
blueman-tray version 2.1.alpha1 starting
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.GameControllerWakelock.GameControllerWakelock'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.NMPANSupport.NMPANSupport'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.StandardItems.StandardItems'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.RecentConns.RecentConns'>
blueman-applet 12.58.04 INFO     PluginManager:155 __load_plugin: loading <class 'blueman.plugins.applet.TransferService.TransferService'>
blueman-applet 12.58.04 INFO     KillSwitch:104 io_event  : killswitch registered 1
blueman-applet 12.58.04 INFO     KillSwitch:120 io_event  : State: True
blueman-applet 12.58.04 INFO     PowerManager:169 UpdatePowerState: off False | foff False | on True | current state True | new state True
blueman-applet 12.58.04 INFO     KillSwitch:104 io_event  : killswitch registered 2
blueman-applet 12.58.04 INFO     KillSwitch:120 io_event  : State: True
blueman-applet 12.58.04 INFO     PowerManager:169 UpdatePowerState: off False | foff False | on True | current state True | new state True
blueman-applet 12.58.04 INFO     KillSwitch:85 _on_connman_vanished: net.connman vanished
blueman-applet 12.58.04 INFO     Applet:47 _on_dbus_name_appeared: org.bluez :1.0
blueman-applet 12.58.04 INFO     BluezAgent:78 register_agent: Register Agent
blueman-applet 12.58.04 ERROR    PluginManager:209 Run       : Function on_manager_state_changed on DiscvManager failed
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/blueman/main/PluginManager.py", line 206, in Run
    ret = getattr(inst, func)(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blueman/plugins/applet/DiscvManager.py", line 47, in on_manager_state_changed
    self.init_adapter()
  File "/usr/lib/python3.6/site-packages/blueman/plugins/applet/DiscvManager.py", line 67, in init_adapter
    self.adapter = self.parent.Manager.get_adapter()
  File "/usr/lib/python3.6/site-packages/blueman/bluez/Manager.py", line 85, in get_adapter
    raise DBusNoSuchAdapterError("No adapter(s) found")
blueman.bluez.errors.DBusNoSuchAdapterError: No adapter(s) found
blueman-applet 12.58.04 INFO     Networking:68 set_nap   : set nap False
blueman-applet 12.58.04 INFO     RecentConns:97 initialize: rebuilding menu
blueman-applet 12.58.04 INFO     ShowConnected:38 enumerate_connections: Found 0 existing connections
blueman-applet 12.58.04 INFO     TransferService:193 _on_dbus_name_vanished: org.bluez.obex not running or was stopped
blueman-applet 12.58.05 INFO     PowerManager:120 RequestPowerState: Requesting True
blueman-applet 12.58.05 INFO     KillSwitch:136 on_power_state_change_requested: True
blueman-applet 12.58.05 DEBUG    KillSwitch:149 on_power_state_change_requested: Using mechanism to set state: True
blueman-applet 12.58.05 INFO     PowerManager:105 check     : callbacks done
blueman-applet 12.58.05 INFO     PowerManager:76 set_adapter_state: True
blueman-applet 12.58.05 INFO     PowerManager:169 UpdatePowerState: off False | foff False | on True | current state True | new state True
Furthermore, "bluetoothctl list" gave no output, although Airplane mode is off (other networking methods function normally).

Running "bluetoothctl":

[bluetooth]# pair
Missing device address argument
[bluetooth]# head -1 $(which blueman-applet)
[bluetooth]#

"journalctl" gave this related output:
Apr 22 11:36:15 localhost.localdomain kernel: Bluetooth: hci0: don't support firmware rome 0x31010000

"hciconfig" gives me:

hci0:   Type: Primary  Bus: USB
        BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
        DOWN 
        RX bytes:0 acl:0 sco:0 events:0 errors:0
        TX bytes:0 acl:0 sco:0 commands:0 errors:0

"hciconfig hci0 reset":

Can't init device hci0: Input/output error (5)

Comment 8 nada81 2018-04-27 07:05:42 UTC
same problem for me with bluez update

Comment 9 Hans de Goede 2018-04-27 08:55:19 UTC
Hi All,

I've submitted a patch reverting the changes which are causing this problem upstream. In the mean we are also working upstream to replace those changes with something which does not break bluetooth on your hardware. As some changes are necessary to get some bluetooth to work on some (other) laptops.

I've prepared a test-kernel build which not only includes the revert, but also a new patch which should fix the problem the original patch tried to address while not breaking bluetooth on your devices.

This is currently building here:
https://koji.fedoraproject.org/koji/taskinfo?taskID=26589252
Note it will take a couple of hours for this to finish building.

Please see the generic instructions for installing and testing test-kernels here:
https://fedorapeople.org/~jwrdegoede/kernel-test-instructions.txt

And let us know if this specific kernel builds results in working bluetooth for you.

Thanks & Regards,

Hans

Comment 10 nada81 2018-04-27 17:18:37 UTC
i have an update kernel --> 4.16.3-200.fc27 but the problem stay.

Comment 11 M. Kristall 2018-04-27 17:50:16 UTC
With 4.16.4-300.rhbz1568911.fc28.x86_64, bluetooth does work to an extent, though devices do keep randomly disconnecting or refusing to connect.

Comment 12 bionan_2000 2018-04-28 08:38:00 UTC
With 4.16.4-300.rhbz1568911.fc28.x86_64, bluetooth does work! I connected with my smartphone, transfer files and all worked well (Lenovo ideapad z500)

Comment 13 Hans de Goede 2018-04-28 18:49:29 UTC
(In reply to M. Kristall from comment #11)
> With 4.16.4-300.rhbz1568911.fc28.x86_64, bluetooth does work to an extent,
> though devices do keep randomly disconnecting or refusing to connect.

That sounds like an unrelated problem, the regression was the bluetooth controller no longer being recognized at all.

(In reply to bionan_2000 from comment #12)
> With 4.16.4-300.rhbz1568911.fc28.x86_64, bluetooth does work! I connected
> with my smartphone, transfer files and all worked well (Lenovo ideapad z500)

Thank you for testing.

Comment 14 nada81 2018-04-30 07:41:33 UTC
with a kernel update 4.16.4-200 don't work

Comment 15 Jeremy Cline 2018-04-30 13:28:25 UTC
*** Bug 1573036 has been marked as a duplicate of this bug. ***

Comment 16 nada81 2018-05-03 12:05:46 UTC
with update to F28 --> Don't work (kernel 4.16.5.300)

Comment 17 Neyzan 2018-05-03 21:18:04 UTC
When I tried to install the testing kernel I got the message that it is not possible to install because a newer version is already installed. The same after upgrading to Fedora 28. I finally installed it with "rpm -ivh --oldpackage kernel*.rpm". Bluetooth works with this kernel, although the icon of Blueman does not show in the system tray and the PC is responding slower.

Comment 18 nada81 2018-05-06 20:24:06 UTC
with update F28 kernel 4.16.6-302.fc28.x86_64 --> Don't work!

Comment 19 Hans de Goede 2018-05-07 09:39:44 UTC
Nada81,

If you think you're impacted by this bug, try using the provided test-kernel from: https://fedorapeople.org/~jwrdegoede/rhbz1568911/  Installation instructions are here: https://fedorapeople.org/~jwrdegoede/kernel-test-instructions.txt

Neyzan,

Good to hear that the test kernel works for you, the fix for this is not yet in the official Fedora kernels, so I advice you to use the test kernel for now.

Fedora kernel team,

For some reason the upstreaming of the revert fixing this is going somewhat slow, can you add this as a downstream patch to the Fedora kernels for now? :

https://git.kernel.org/pub/scm/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=0e40528b044110caf85895e375323ab5cdb052a3

Regards,

Hans

Comment 20 nada81 2018-05-09 13:16:18 UTC
Hi, 
Ok but i prefer to wait the implementation in the official kernel...do you know how much time this will take ?

Thank you very much

Regards

Comment 21 nada81 2018-05-10 12:08:01 UTC
with update kernel 4.16.7-300.fc28.x86_64 today --> don't work

Comment 22 Tim Landscheidt 2018-05-21 08:28:43 UTC
With Hans's kernel-core-4.16.4-300.rhbz1568911.fc28.x86_64, Bluetooth works again in Fedora 27 with "Qualcomm Atheros Communications AR3012 Bluetooth 4.0" (bedankt!); it did not work with kernel-core-4.16.7-200.fc27.x86_64.

Comment 23 nada81 2018-05-24 10:04:18 UTC
Hi, 
Ok but i prefer to wait the implementation in the official kernel...do you know how much time this will take ?

Thank you very much

Regards

Comment 24 Hans de Goede 2018-05-24 10:10:41 UTC
kernel versions 4.16.9 and newer have the fix for this, current updates-testing has 4.16.10, so this is fixed now, closing.


Note You need to log in before you can comment on or make changes to this bug.