Bug 1565049 - [upstream][v2v] Migration requests are appearing in 'My Order' of SSUI
Summary: [upstream][v2v] Migration requests are appearing in 'My Order' of SSUI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: V2V
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Daniel Berger
QA Contact: Dave Johnson
Steve Bream
URL:
Whiteboard: v2v
Depends On:
Blocks: 1668816
TreeView+ depends on / blocked
 
Reported: 2018-04-09 09:02 UTC by Yadnyawalk Tale
Modified: 2020-03-20 19:40 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-12 19:18:09 UTC
Category: Bug
Cloudforms Team: V2V
Target Upstream Version:


Attachments (Terms of Use)
reproducible_master.20180517.png (77.22 KB, image/png)
2018-05-22 20:16 UTC, Yadnyawalk Tale
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1610729 0 high CLOSED Remove migration plans from Service Catalog Items 2021-02-22 00:41:40 UTC

Internal Links: 1610729

Comment 4 John Prause 2018-05-16 12:30:16 UTC
Reassigning to Brett after e-mail conversation.

Comment 7 Brett Thurber 2018-05-22 18:40:38 UTC
@Ytale....can you test and see if this is still and issue?  This was reported on the POC UI.  If so please file a PR upstream.

Comment 8 Yadnyawalk Tale 2018-05-22 20:16:04 UTC
Created attachment 1440294 [details]
reproducible_master.20180517.png

@Brett, issue is not fixed yet, I can still reproduce this under newest UI.
Created upstream github issue - https://github.com/ManageIQ/miq_v2v_ui_plugin/issues/341

Thing to note, only creating Infra map will not create that order in SSUI, you have to run migration plan.

Reproduced on: upstream/master.20180517233405_6f8f0cd

Comment 19 Sudhir Mallamprabhakara 2018-08-01 14:40:56 UTC
moving this to 5.10 due to this https://github.com/ManageIQ/manageiq-ui-service/issues/1463

Comment 32 Rich Oliveri 2018-12-10 22:29:18 UTC
Sorry Brett, assigning this BZ to myself so I don't lose track of it again.
I'll assign it once I determine who should handle it.

Comment 37 CFME Bot 2020-03-20 19:36:13 UTC
New commit detected on ManageIQ/manageiq-schema/jansa:

https://github.com/ManageIQ/manageiq-schema/commit/161e81afa0bc49afa96ad209fc4a21884c113944
commit 161e81afa0bc49afa96ad209fc4a21884c113944
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Fri Mar  6 13:19:30 2020 +0000
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Fri Mar  6 13:19:30 2020 +0000

    Merge pull request #452 from gmcculloug/service_order_sti

    Add type column to service_order table

    (cherry picked from commit de5848d8ee7dbec88ad48d2a28707673467913c2)

    https://bugzilla.redhat.com/show_bug.cgi?id=1565049

 db/migrate/20200128122000_add_type_column_to_service_order.rb | 27 +
 spec/dummy/config/database.yml | 2 -
 spec/migrations/20200128122000_add_type_column_to_service_order_spec.rb | 23 +
 3 files changed, 50 insertions(+), 2 deletions(-)

Comment 38 CFME Bot 2020-03-20 19:40:21 UTC
New commit detected on ManageIQ/manageiq/jansa:

https://github.com/ManageIQ/manageiq/commit/7fe095eab167c1b6fdb56dd28e663809b43a3412
commit 7fe095eab167c1b6fdb56dd28e663809b43a3412
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Fri Mar  6 13:19:55 2020 +0000
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Fri Mar  6 13:19:55 2020 +0000

    Merge pull request #19795 from gmcculloug/service_cart_sub_classes

    Create ServiceOrder sub-classes

    (cherry picked from commit ec56ab47c4baa27b12cd00d67e49e8f2a1109321)

    https://bugzilla.redhat.com/show_bug.cgi?id=1565049

 app/models/service_order.rb | 24 +-
 app/models/service_order_cart.rb | 2 +
 app/models/service_order_v2v.rb | 2 +
 app/models/service_template_provision_request.rb | 1 +
 app/models/service_template_transformation_plan_request.rb | 1 +
 spec/factories/service_order.rb | 3 +
 spec/models/service_order_spec.rb | 9 +-
 spec/models/service_template_provision_request_spec.rb | 5 +
 spec/models/service_template_transformation_plan_request_spec.rb | 13 +
 9 files changed, 49 insertions(+), 11 deletions(-)


Note You need to log in before you can comment on or make changes to this bug.