Bug 1565061 - swap volume attempts between an unencrypted and encrypted volume type still allowed
Summary: swap volume attempts between an unencrypted and encrypted volume type still a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Upstream M1
: 14.0 (Rocky)
Assignee: Lee Yarwood
QA Contact: Archit Modi
URL:
Whiteboard:
Depends On:
Blocks: 1565587
TreeView+ depends on / blocked
 
Reported: 2018-04-09 09:47 UTC by Lee Yarwood
Modified: 2019-09-09 17:02 UTC (History)
10 users (show)

Fixed In Version: openstack-nova-18.0.0-0.20180625215857.9a8a98b.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1565587 (view as bug list)
Environment:
Last Closed: 2019-01-11 11:49:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1749418 0 None None None 2018-04-09 09:47:11 UTC
OpenStack gerrit 544238 0 None None None 2018-04-09 09:49:20 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:49:45 UTC

Description Lee Yarwood 2018-04-09 09:47:11 UTC
Description of problem:
As detailed in the below upstream bug report swapping from an unencrypted volume to an encrypted volume is still allowed. These attempts need to be blocked until libvirt RFE RHBZ#760547 is resolved.

swap volume not blocked between an unencrypted and encrypted volume while using QEMU to natively decrypt
https://bugs.launchpad.net/nova/+bug/1749418

Version-Release number of selected component (if applicable):
17.0.0

How reproducible:
Always

Steps to Reproduce:
1. nova volume-update ${instance_uuid} ${unencrypted_volume_uuid} ${encrypted_volume_uuid}

Actual results:
Attempt made to swap volumes.

Expected results:
NotImplementedError raised.

Additional info:

Comment 7 errata-xmlrpc 2019-01-11 11:49:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.