Bug 1565587 - swap volume attempts between an unencrypted and encrypted volume type still allowed
Summary: swap volume attempts between an unencrypted and encrypted volume type still a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Lee Yarwood
QA Contact: Archit Modi
URL:
Whiteboard:
Depends On: 1565061
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 11:13 UTC by Lee Yarwood
Modified: 2019-09-09 16:08 UTC (History)
11 users (show)

Fixed In Version: openstack-nova-17.0.3-0.20180417162852.991c292.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1565061
Environment:
Last Closed: 2018-06-27 13:50:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1749418 None None None 2018-04-10 11:13:11 UTC
OpenStack gerrit 559987 None stable/queens: MERGED nova: libvirt: Block swapping to an encrypted volume when using QEMU to decrypt (I258127fdcd011ccec721d5ff62eb7f128f1303... 2018-04-20 15:37:49 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:34 UTC

Description Lee Yarwood 2018-04-10 11:13:11 UTC
+++ This bug was initially created as a clone of Bug #1565061 +++

Description of problem:
As detailed in the below upstream bug report swapping from an unencrypted volume to an encrypted volume is still allowed. These attempts need to be blocked until libvirt RFE RHBZ#760547 is resolved.

swap volume not blocked between an unencrypted and encrypted volume while using QEMU to natively decrypt
https://bugs.launchpad.net/nova/+bug/1749418

Version-Release number of selected component (if applicable):
17.0.0

How reproducible:
Always

Steps to Reproduce:
1. nova volume-update ${instance_uuid} ${unencrypted_volume_uuid} ${encrypted_volume_uuid}

Actual results:
Attempt made to swap volumes.

Expected results:
NotImplementedError raised.

Additional info:

Comment 8 errata-xmlrpc 2018-06-27 13:50:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.