Bug 1565178 - [RFE] Manage snapshots through 'VM Portal' on RHV-4.2 [NEEDINFO]
Summary: [RFE] Manage snapshots through 'VM Portal' on RHV-4.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-web-ui
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.3.0
: ---
Assignee: biakymet
QA Contact: samuel macko
URL:
Whiteboard:
Depends On:
Blocks: 1622541 1672787
TreeView+ depends on / blocked
 
Reported: 2018-04-09 14:35 UTC by Beni Pelled
Modified: 2019-05-16 13:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, you could manage snapshots through the Administration Portal, but not in the VM Portal. In the current release, you can manage snapshots through the VM portal.
Clone Of:
: 1622541 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:35:10 UTC
oVirt Team: UX
Target Upstream Version:
rdlugyhe: needinfo? (biakymet)
rdlugyhe: needinfo? (biakymet)
lleistne: testing_plan_complete+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-web-ui issues 573 0 'None' closed VM Snapshot management 2021-02-04 07:10:47 UTC
Red Hat Product Errata RHBA-2019:1068 0 None None None 2019-05-08 12:35:16 UTC

Description Beni Pelled 2018-04-09 14:35:37 UTC
Description of problem:
There is no option to manage snapshots (create/edit/delete etc.) through the 'VM Portal' on RHV-4.2,
(of course it is possible through the webadmin)

Version-Release number of selected component (if applicable):
4.2.*

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
It's basic requirement to allow users to manage their snapshots themselves,
This was possible in on RHV-3.*

Comment 1 Yaniv Kaul 2018-04-09 17:14:52 UTC
Michal - do we have any plans to add basic abilities here?

Comment 2 Michal Skrivanek 2018-04-10 06:54:06 UTC
not planned.
Snapshot functionality was not part of Basic User Portal functionality, only Power User Portal had that.

@bpelled, feel free to open upstream issue describing the use case and proposed scope/design

Comment 3 Yaniv Lavi 2018-04-30 07:55:09 UTC
Snapshots management is a basic feature to allow user to be independent and not need oVirt admin to micro manage the users.
I proposing this as high priority for 4.2 as I expect users to hit this issue on GA and have a poor transition experience from the old user portal.

Comment 7 Michal Skrivanek 2018-07-16 14:18:30 UTC
snapshot support is being actively worked on in upstream, we're looking tentatively to include an update in 4.2.6

Comment 11 samuel macko 2019-03-04 15:14:49 UTC
Verified on ovirt-engine-4.3.0.4-0.1.el7.noarch.
VM Portal offers functionality to create, delete and restore snapshots.

Comment 15 errata-xmlrpc 2019-05-08 12:35:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1068

Comment 16 Franta Kust 2019-05-16 13:03:01 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.