Bug 1565184 - API deletion of non-existent hosts causes stuck deletion tasks on Satellite 6.2
Summary: API deletion of non-existent hosts causes stuck deletion tasks on Satellite 6.2
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.2.14
Hardware: All
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: tstrych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 14:49 UTC by Ash Westbrook
Modified: 2019-12-03 12:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:53:41 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ash Westbrook 2018-04-09 14:49:27 UTC
Description of problem:

Roughly 30 tasks for 'Destroy Content Host' are in a paused/error state. Resuming the jobs does not help.  Exception: RestClient::InternalServerError: 500 Internal Server Error.

This is caused when VMs that were created by CloudForms and then are deleted from CloudForms cause stuck state in Satellite 6.

Version-Release number of selected component (if applicable):

CFME 5.7
Satellite 6.2.14

How reproducible:

Always


Additional info:

Attached reports from the case, 02066982 and closed CFME BZ 1564582.

Comment 8 Bryan Kearney 2019-11-04 14:34:09 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 9 Bryan Kearney 2019-12-03 12:53:41 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.