Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565310 - mount.nfs can not mount nfsv3 exports
Summary: mount.nfs can not mount nfsv3 exports
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-09 20:01 UTC by Pierre-Francois RENARD
Modified: 2018-06-02 06:52 UTC (History)
6 users (show)

Fixed In Version: nfs-utils-2.3.1-7.rc1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-15 02:40:20 UTC
Type: Bug


Attachments (Terms of Use)
data.pcap.bz2 (1.44 KB, application/x-bzip)
2018-04-09 21:25 UTC, Pierre-Francois RENARD
no flags Details

Description Pierre-Francois RENARD 2018-04-09 20:01:30 UTC
Description of problem:
mount.nfs can not mount nfs v3 exports 

Version-Release number of selected component (if applicable):
Fedora 28 - aarch64 
kernel 4.16.0-300.fc28.aarch64

How reproducible:
each time

Steps to Reproduce:
1. try to mount a NFS v3 export
2.
3.

Actual results:
mount -t nfs syno01:/volume1/data /tmp/mnt
mount.nfs: Protocol not supported
it does not work

mount -t nfs -o "vers=3"  syno01:/volume1/data /tmp/mnt
it works

Expected results:


Additional info:

mount -t nfs syno01:/volume1/data /tmp/mnt
mount.nfs: Protocol not supported

mount -t nfs -o "vers=3"  syno01:/volume1/data /tmp/mnt
 


mount -v -t nfs syno01:/volume1/data /tmp/mnt
gives

mount.nfs: timeout set for Mon Apr  9 22:00:46 2018
mount.nfs: trying text-based options 'vers=4.2,addr=172.16.1.51,clientaddr=172.16.1.211'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,minorversion=1,addr=172.16.1.51,clientaddr=172.16.1.211'
mount.nfs: mount(2): Protocol not supported
mount.nfs: trying text-based options 'vers=4,addr=172.16.1.51,clientaddr=172.16.1.211'
mount.nfs: mount(2): Protocol not supported
mount.nfs: Protocol not supported


mount -v -t nfs -o vers=3 syno01:/volume1/data /tmp/mnt
gives

mount.nfs: timeout set for Mon Apr  9 22:01:43 2018
mount.nfs: trying text-based options 'vers=3,addr=172.16.1.51'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 172.16.1.51 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 172.16.1.51 prog 100005 vers 3 prot UDP port 892

Comment 1 Steve Dickson 2018-04-09 20:07:44 UTC
What is the output of "rpcinfo -p syno01"

Comment 2 Pierre-Francois RENARD 2018-04-09 20:22:48 UTC
rpcinfo -p syno01
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100005    1   udp    892  mountd
    100005    1   tcp    892  mountd
    100005    2   udp    892  mountd
    100005    2   tcp    892  mountd
    100005    3   udp    892  mountd
    100005    3   tcp    892  mountd
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100021    1   udp  39538  nlockmgr
    100021    3   udp  39538  nlockmgr
    100021    4   udp  39538  nlockmgr
    100021    1   tcp  38216  nlockmgr
    100021    3   tcp  38216  nlockmgr
    100021    4   tcp  38216  nlockmgr
    100024    1   udp  45217  status
    100024    1   tcp  48448  status


also it is perfectly working with f27 (armhfp and x86_64)

Comment 3 Steve Dickson 2018-04-09 20:51:22 UTC
Thank you for your quick reply! 

(In reply to RENARD from comment #2)
> rpcinfo -p syno01
>    program vers proto   port  service
>     100003    2   tcp   2049  nfs
>     100003    3   tcp   2049  nfs
>     100003    2   udp   2049  nfs
>     100003    3   udp   2049  nfs
It appears v4 is not supported by the server.... 
What server is this? 

Would it get possible to get a tshark network trace 
of the mount? From the client

tshark -w /tmp/data.pcap host syno01
bzip2 /tmp/data.pcap

> also it is perfectly working with f27 (armhfp and x86_64)
fair enough...

Comment 4 Pierre-Francois RENARD 2018-04-09 21:24:56 UTC
this is a synology nas server, I did not configured NFS V4.
As I said it is working with F27:)

data.pcap.bz2 attached

Comment 5 Pierre-Francois RENARD 2018-04-09 21:25:48 UTC
Created attachment 1419570 [details]
data.pcap.bz2

Comment 6 Fedora Update System 2018-04-11 15:57:31 UTC
nfs-utils-2.3.1-7.rc1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5f49d4050a

Comment 7 Fedora Update System 2018-04-11 22:59:59 UTC
nfs-utils-2.3.1-7.rc1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5f49d4050a

Comment 8 Fedora Update System 2018-04-15 02:40:20 UTC
nfs-utils-2.3.1-7.rc1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Havoc Pennington 2018-05-31 03:20:03 UTC
Pierre-Francois is this working for you now? With nfs-utils 2.3.1-9.rc1.fc28.x86_64 it does not seem to work for me from a new install of Fedora 28 on a new laptop; working fine at the same moment from fedora 27 on old laptop. My NFS server is also Synology with nfs v3.
Same fstab on both.
Behavior from Fedora 28 is for the `mount --verbose` to fail with `portmap query failed: RPC: timed out`

Comment 10 Havoc Pennington 2018-06-02 04:10:03 UTC
In case anyone else googles this in the future, for me the problem was that mdns isn't on by default. (NAS on diskstation.local)
nfs-utils is fine

Comment 11 Pierre-Francois RENARD 2018-06-02 06:52:22 UTC
all is working fine for me. Bug solved:)


Note You need to log in before you can comment on or make changes to this bug.