Bug 1565534 - [UI] - Reverse the title and the entity on the NIC panel - MAC, Statistics and for the new vNIC design
Summary: [UI] - Reverse the title and the entity on the NIC panel - MAC, Statistics an...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.2.6
Hardware: x86_64
OS: Linux
low
low vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
: 1563651 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 09:09 UTC by Michael Burman
Modified: 2018-06-26 08:44 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:44:54 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ylavi: exception+


Attachments (Terms of Use)
screenshots (18.56 KB, application/x-gzip)
2018-04-10 09:09 UTC, Michael Burman
no flags Details
VM nic redesigned (89.00 KB, application/x-gzip)
2018-04-10 11:06 UTC, Ales Musil
no flags Details
layout for VM nic (57.20 KB, image/jpeg)
2018-04-11 13:30 UTC, Eldan Hildesheim
no flags Details
vm_nic (63.66 KB, image/png)
2018-04-13 12:30 UTC, Ales Musil
no flags Details
Redesign after notes (73.40 KB, application/x-gzip)
2018-04-24 08:31 UTC, Ales Musil
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 90259 master MERGED webadmin: Match VM interfaces design with Host interfaces design 2018-05-07 11:52:41 UTC
oVirt gerrit 90488 master MERGED webadmin: Reverse title and value for host network interface 2018-05-07 12:45:42 UTC
oVirt gerrit 90975 ovirt-engine-4.2 MERGED webadmin: Match VM interfaces design with Host interfaces design 2018-05-09 08:47:14 UTC
oVirt gerrit 90976 ovirt-engine-4.2 MERGED webadmin: Reverse title and value for host network interface 2018-05-09 08:47:18 UTC

Description Michael Burman 2018-04-10 09:09:28 UTC
Created attachment 1419771 [details]
screenshots

Description of problem:
[UI] - Reverse the title and the entity on the NIC panel - MAC, Statistics and for the new vNIC design.

For some reason it was designed that the title is shown under the entity it self on the host NIC panel, but it's wrong.
The MAC and statistics titles coming under the entity it self.
The same should be done for the new design(by amusil) for the VM's vNIC panel - 
Network name, IPv4/6 and MAC

Version-Release number of selected component (if applicable):
4.2.2.6-0.1.el7

How reproducible:
100%

Ales, will it be possible to keep bold text of the NIC name aligned to the bold entity text(MAC address and statistics)? 
Something that Greg for the UI team has done for the current design and i would like to keep this way please. 
If it's possible to keep the bold text as it is and just move the title on top of the bold entity?

Comment 1 Ales Musil 2018-04-10 11:06:18 UTC
In the attachment are both versions (current and reversed) for the VM nic. We just have to decide which one to use.

Comment 2 Ales Musil 2018-04-10 11:06:44 UTC
Created attachment 1419838 [details]
VM nic redesigned

Comment 3 Michael Burman 2018-04-10 11:30:15 UTC
(In reply to Ales Musil from comment #1)
> In the attachment are both versions (current and reversed) for the VM nic.
> We just have to decide which one to use.

Reversed look good to me)

Comment 4 Dan Kenigsberg 2018-04-11 07:23:07 UTC
I actually prefer it when the title is smaller and non-bold. I do not care if it is above and below. I'd like a UX expert to judge.

Comment 5 Eldan Hildesheim 2018-04-11 13:30:17 UTC
Created attachment 1420328 [details]
layout for VM nic

Apart from the titles, I also made simpler the details part:
Aggregated all the small part to 1 window.

Comment 6 Michael Burman 2018-04-11 13:47:21 UTC
Thank you Eldan,
Looks very good to me, ALes what you think?

Comment 7 Ales Musil 2018-04-13 12:30:46 UTC
Created attachment 1421360 [details]
vm_nic

Here is the result.

Comment 8 Michael Burman 2018-04-15 11:03:24 UTC
(In reply to Ales Musil from comment #7)
> Created attachment 1421360 [details]
> vm_nic
> 
> Here is the result.

Hi Ales, looks great, i have 3 comments:
1) We decided to bold the text of the title and not the value, it make more sense 
2) Please align the (Mbps) in the statistics sub tab as Eldan did on attachment in comment 5 , in your screenshots id doesn't aligned. The same should be done for the host NIC panel as well.
3) Note that except re-designing the VM's vNIC, the reverse of the title and value should be done on the host NIC panel as well.

Please send me the screenshot after fixing the comments, 
Thanks,

Comment 9 Dan Kenigsberg 2018-04-17 09:56:01 UTC
(In reply to Michael Burman from comment #8)
> (In reply to Ales Musil from comment #7)
> > Created attachment 1421360 [details]
> > vm_nic
> > 
> > Here is the result.
> 
> Hi Ales, looks great, i have 3 comments:
> 1) We decided to bold the text of the title and not the value, it make more
> sense 

I don't know who has decided this; I very much prefer to keep the value as bold, and title in a thin font. The title is constant and boring and should be kept quiet.

> 2) Please align the (Mbps) in the statistics sub tab as Eldan did on
> attachment in comment 5 , in your screenshots id doesn't aligned. The same
> should be done for the host NIC panel as well.

+1, please do it in a separate patch.

> 3) Note that except re-designing the VM's vNIC, the reverse of the title and
> value should be done on the host NIC panel as well.

+1

Comment 10 Michael Burman 2018-04-17 10:40:33 UTC
(In reply to Dan Kenigsberg from comment #9)
> (In reply to Michael Burman from comment #8)
> > (In reply to Ales Musil from comment #7)
> > > Created attachment 1421360 [details]
> > > vm_nic
> > > 
> > > Here is the result.
> > 
> > Hi Ales, looks great, i have 3 comments:
> > 1) We decided to bold the text of the title and not the value, it make more
> > sense 
> 
> I don't know who has decided this; I very much prefer to keep the value as
> bold, and title in a thin font. The title is constant and boring and should
> be kept quiet.
Eldan, Me and Meni decided this. The title should be bold, because you look for the title and only then looking on it's value. After the reverse, if the value will remain bold it will break the look of the host NIC panel as well. 

> 
> > 2) Please align the (Mbps) in the statistics sub tab as Eldan did on
> > attachment in comment 5 , in your screenshots id doesn't aligned. The same
> > should be done for the host NIC panel as well.
> 
> +1, please do it in a separate patch.
> 
> > 3) Note that except re-designing the VM's vNIC, the reverse of the title and
> > value should be done on the host NIC panel as well.
> 
> +1

Comment 11 Dan Kenigsberg 2018-04-17 11:03:35 UTC
*** Bug 1563651 has been marked as a duplicate of this bug. ***

Comment 12 Dan Kenigsberg 2018-04-17 14:12:15 UTC
> > I don't know who has decided this; I very much prefer to keep the value as
> > bold, and title in a thin font. The title is constant and boring and should
> > be kept quiet.
> Eldan, Me and Meni decided this. The title should be bold, because you look
> for the title and only then looking on it's value. After the reverse, if the
> value will remain bold it will break the look of the host NIC panel as well. 

Ok, I am not going to fight against Eldan regarding UX (even though he's still wrong). Let the title be bold.

Comment 13 Ales Musil 2018-04-24 08:31:07 UTC
Created attachment 1425865 [details]
Redesign after notes

Here is redesign after fixing the notes.

Comment 14 Michael Burman 2018-05-27 07:52:30 UTC
Verified on - 4.2.4-0.1.el7

Comment 15 Michael Burman 2018-05-27 07:53:49 UTC
Alignment of the (mbps) wasn't fixed here, i will report new bug for this.

Comment 16 Sandro Bonazzola 2018-06-26 08:44:54 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.