Bug 1565543 - dnf module install dosen't work if no profile is given
Summary: dnf module install dosen't work if no profile is given
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1565660 (view as bug list)
Depends On:
Blocks: 1478068
TreeView+ depends on / blocked
 
Reported: 2018-04-10 09:21 UTC by lnie
Modified: 2018-11-22 18:21 UTC (History)
7 users (show)

Fixed In Version: dnf-4.0.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-22 18:21:41 UTC
Type: Bug


Attachments (Terms of Use)

Description lnie 2018-04-10 09:21:23 UTC
Description of problem:
[root@localhost ~]# dnf module install django:1.6
Last metadata expiration check: 0:39:29 ago on Tue 10 Apr 2018 04:21:23 PM CST.
No profile specified for 'django:1.6', please specify profile
Nothing to install. Enabled modules: django:1.6

According to man page dnf module install pkg should install the default module profile is no profile is offered which is the wanted action.
 dnf [options] module install <module_spec>...
  Dnf  will make sure that RPMs from specified module profile or, in case no profile was provided, default module profile are installed. 

Btw,I'm new to dnf module install so I don't know how to specify module profile at all and failed to find the answer in the man page

Version-Release number of selected component (if applicable):

dnf-2.7.5-8.fc28.noarch

How reproducible:

always 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Martin Hatina 2018-04-10 09:27:43 UTC
Hi, can you run 'dnf module info django:1.6' command and provide the output? Thank you.

Comment 2 lnie 2018-04-10 09:36:09 UTC
[root@localhost ~]# dnf module info django:1.6
Last metadata expiration check: 1:14:08 ago on Tue 10 Apr 2018 04:21:23 PM CST.

Name        : django
Stream      : 1.6
Version     : 20180328170906
Profiles    : default python2_development
Repo        : updates-testing-modular
Summary     : A high-level Python Web framework
Description : Django is a high-level Python Web framework that encourages rapid development and a clean, pragmatic design. It focuses on automating as much as possible and adhering to the DRY (Don't Repeat Yourself) principle.
Artifacts   : python-django-bash-completion-0:1.6.11.7-2.module_1595+34c51ab8.noarch
            : python2-django-0:1.6.11.7-2.module_1595+34c51ab8.noarch

Comment 3 lnie 2018-04-10 09:49:35 UTC
Hi,I withdraw "failed to find the answer in the man page",there is info in man page,and I find dnf module disable dosen't work as I can do dnf module install reviewboard:2.5/default after disable it.

Comment 4 Martin Hatina 2018-04-10 09:53:01 UTC
There is no default profile for django:1.6, but there is 'default' profile. Can you update your dnf and try 'dnf module install django:1.6' again? Thank you.

Comment 5 lnie 2018-04-11 03:01:05 UTC
updated the dnf to the latest from koji
[root@localhost ~]# rpm -q dnf
 dnf-2.7.5-9.fc28.noarch
[root@localhost ~]# dnf module info django:1.6
Fedora 28 - x86_64 - Test Updates                                                                                                                        322 kB/s |  15 MB     00:47    
Last metadata expiration check: 0:00:00 ago on Wed 11 Apr 2018 10:59:04 AM CST.

Name        : django
Stream      : 1.6
Version     : 20180328170906
Profiles    : default python2_development
Repo        : updates-testing-modular
Summary     : A high-level Python Web framework
Description : Django is a high-level Python Web framework that encourages rapid development and a clean, pragmatic design. It focuses on automating as much as possible and adhering to the DRY (Don't Repeat Yourself) principle.
Artifacts   : python-django-bash-completion-0:1.6.11.7-2.module_1595+34c51ab8.noarch
            : python2-django-0:1.6.11.7-2.module_1595+34c51ab8.noarch

Comment 6 Martin Hatina 2018-04-11 10:26:35 UTC
*** Bug 1565660 has been marked as a duplicate of this bug. ***

Comment 7 Martin Hatina 2018-04-11 10:34:22 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/1054

Comment 8 lnie 2018-09-14 10:39:31 UTC
Still with dnf-3.2.0-2.fc29.noarch

Comment 9 lnie 2018-09-20 09:11:14 UTC
I'm able to module install ant,dwm:6.1,maven:3.5 django:1.6 without giving any profile,seems [d] is the reason,so we can make other modules work the same way right? Though I can't install reviewboard and stratis which also have [d],and the output is kind of mess and confusing,I'm gonna to open a new bug for the confusing output.
root@localhost-live lnie]# dnf module list
Last metadata expiration check: 0:21:10 ago on Thu 20 Sep 2018 04:26:49 PM CST.
Fedora Modular 29 - x86_64
Name             Stream         Profiles                        Summary                                         ant              1.10           default [d]                     Java build tool
....
django           1.6            python2_development, default [d A high-level Python Web framework               ] 
....
dwm              6.0            user, default [d]               Dynamic window manager for X                    
dwm              6.1 [d]        user, default [d]               Dynamic window manager for X                    
dwm              latest         user, default [d]               Dynamic window manager for X         
...
maven            3.5            default [d]                   Java project management and project comprehension tool
reviewboard      2.5            server, default [d]             A web-based code review tool                    
reviewboard      3.0            server, default [d]             A web-based code review tool
...
stratis          master [d]     default [d]                     Stratis Storage


Note You need to log in before you can comment on or make changes to this bug.