Bug 1565660 - dnf module install MODULE:STREAM without profile does not work
Summary: dnf module install MODULE:STREAM without profile does not work
Keywords:
Status: CLOSED DUPLICATE of bug 1565543
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 13:54 UTC by Miroslav Suchý
Modified: 2018-04-11 10:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-11 10:26:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Miroslav Suchý 2018-04-10 13:54:05 UTC
Description of problem:
Documentation (man page) state (emphasis mine):
 dnf [options] module install <module_spec>...
              Dnf will make sure that RPMs from specified module profile or, in **case no profile  was  provided,  default  module  profile**  are
              installed.  Dnf will also make sure module stream is enabled after.

But when I try:
#  dnf module install container-tools:2017.0

I get:

No profile specified for 'container-tools:2017.0', please specify profile


And BTW you are missing dot at the end of that line of the error.

Comment 1 Martin Hatina 2018-04-11 10:26:35 UTC

*** This bug has been marked as a duplicate of bug 1565543 ***


Note You need to log in before you can comment on or make changes to this bug.