Bug 1565968 - Fail to update graphic listen type by virt-xml
Summary: Fail to update graphic listen type by virt-xml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1690687
TreeView+ depends on / blocked
 
Reported: 2018-04-11 08:05 UTC by Xiaodai Wang
Modified: 2019-08-06 13:08 UTC (History)
4 users (show)

Fixed In Version: virt-manager-1.5.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1690687 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:07:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2232 None None None 2019-08-06 13:08:11 UTC

Description Xiaodai Wang 2018-04-11 08:05:51 UTC
Description of problem:
Fail to update graphic info by virt-xml

Version-Release number of selected component (if applicable):
virt-manager-1.4.3-3.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. set graphics listen type to socket or none
    <graphics type='vnc'>
      <listen type='socket'/>
    </graphics>
2. update graphics listen to 127.0.0.1.
# virt-xml test1 --edit --graphics listen=127.0.0.1

Actual results:
#  /usr/share/virt-manager/virt-xml test1 --edit --graphics listen=127.0.0.1 --debug
[Wed, 11 Apr 2018 15:58:27 virt-xml 25497] DEBUG (cli:264) Launched with command line: /usr/share/virt-manager/virt-xml test1 --edit --graphics listen=127.0.0.1 --debug
[Wed, 11 Apr 2018 15:58:27 virt-xml 25497] DEBUG (cli:278) Requesting libvirt URI default
[Wed, 11 Apr 2018 15:58:27 virt-xml 25497] DEBUG (cli:281) Received libvirt URI qemu:///system
[Wed, 11 Apr 2018 15:58:27 virt-xml 25497] DEBUG (virt-xml:64) XML diff:
--- Original XML
+++ Altered XML
@@ -70,7 +70,7 @@
     </console>
     <input type="mouse" bus="ps2"/>
     <input type="keyboard" bus="ps2"/>
-    <graphics type="vnc">
+    <graphics type="vnc" listen="127.0.0.1">
       <listen type="socket"/>
     </graphics>
     <video>

Domain 'test1' defined successfully.

virt-xml did not update listen type to address so that the modify didn't take effect but reports successfully.

Expected results:
virt-xml should modify listen type and listen address successfully.

Additional info:

Comment 2 Pavel Hrdina 2019-02-28 11:21:28 UTC
Upstream commit:

commit a0b42327c6bb587c20628f8bc946c6041f61818a
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Fri Feb 22 16:32:39 2019 +0100

    graphics: move all listen code into one place

Comment 5 ysu@redhat.com 2019-04-28 08:02:45 UTC
I can reproduce this issue with package:
virt-manager-1.4.3-3.el7.noarch

Then try to verify this bug with new build:
virt-manager-1.5.0-3.el7.noarch
virt-install-1.5.0-3.el7.noarch
libvirt-4.5.0-12.el7.x86_64
qemu-kvm-rhev-2.12.0-26.el7.x86_64
libvirt-python-4.5.0-1.el7.x86_64

Steps:
Scenario-1
1.Set graphics listen type to none.

<graphics type='vnc'>
      <listen type='none'/>
</graphics>

2.Check modification of listen type and listen address on virt-xml successfully.
2.1#virt-xml test1 --edit --graphics listen=127.0.0.1
   Domain test1 XML configuration edited.
2.2#virsh dumpxml test1 | grep graphics                                                                                  
<graphics type='vnc' port='-1' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
</graphics>

Result:Listen type is changed from 'none' to 'address' and address is added successfully.

Scenario-2
1.Set graphics listen type to socket.

<graphics type='vnc'>
      <listen type='socket'/>
</graphics>

2.Check modification of listen type and listen address on virt-xml successfully.
2.1#virt-xml test1 --edit --graphics listen=127.0.0.1
   Domain test1 XML configuration edited.
2.2#virsh dumpxml test1 | grep graphics
<graphics type='vnc' port='-1' autoport='yes' listen='127.0.0.1'>
      <listen type='address' address='127.0.0.1'/>
</graphics>

Result:Listen type is changed from 'socket' to 'address' and address is added successfully.

So based on above two scenarios, I move thist bug from ON_QA to VERIFIED.

Comment 7 errata-xmlrpc 2019-08-06 13:07:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2232


Note You need to log in before you can comment on or make changes to this bug.