Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1565984 - IBus CandidatePopup position is not correct in Wayland
Summary: IBus CandidatePopup position is not correct in Wayland
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1553096 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 09:04 UTC by Pooja Yadav
Modified: 2018-04-20 03:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-20 03:02:50 UTC
Type: Bug


Attachments (Terms of Use)
Alignment is not proper when we search anything on Activities menu screen. (690.12 KB, image/png)
2018-04-11 09:04 UTC, Pooja Yadav
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab 114 0 None None None 2018-04-11 11:57:57 UTC

Description Pooja Yadav 2018-04-11 09:04:24 UTC
Created attachment 1420236 [details]
Alignment is not proper when we search anything on Activities menu screen.

Description of problem:
When we select any input method like kana-kanji,intelligent-pinyin(chinese), or any typing booster. Then search anything in Activities menu, alignment is not proper during input. Refer screenshot


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Add input method such as kana-kanji or intelligent-pinyin.
2. Click on Activities and type anything in search box for eg.-terminal


Actual results:
The candidate window showing suggestions is not aligned properly.

Expected results:
The candidate window should be aligned properly with mouse pointer.

Additional info:

Comment 1 fujiwara 2018-04-11 11:39:21 UTC
The set_cursor_location does not get the position in the root window in Wayland.

Seems clutter_input_method_set_cursor_location_relative() is not implemented for Wayland.

Comment 2 fujiwara 2018-04-11 11:40:16 UTC
*** Bug 1553096 has been marked as a duplicate of this bug. ***

Comment 4 fujiwara 2018-04-18 04:45:50 UTC
I cannot reproduce this with gnome-shell-3.28.1-1 and mutter-3.28.1-1.

Comment 5 Pooja Yadav 2018-04-19 10:03:11 UTC
(In reply to fujiwara from comment #4)
> I cannot reproduce this with gnome-shell-3.28.1-1 and mutter-3.28.1-1.

This bug was reported with below version:
mutter-3.28.0-1.fc28.x86_64
gnome-shell-3.28.0-1.fc28.x86_64

Comment 6 fujiwara 2018-04-19 10:27:55 UTC
(In reply to Pooja Yadav from comment #5)
> (In reply to fujiwara from comment #4)
> > I cannot reproduce this with gnome-shell-3.28.1-1 and mutter-3.28.1-1.
> 
> This bug was reported with below version:
> mutter-3.28.0-1.fc28.x86_64
> gnome-shell-3.28.0-1.fc28.x86_64

Yeah, I think it's good to try the latest version if you still can reproduce this problem.

# dnf update gnome-shell mutter

Comment 7 Pooja Yadav 2018-04-19 10:55:51 UTC
Candidate popup position is now correct.
Verified with below versions:
gnome-shell-3.28.1-1.fc28.x86_64
mutter-3.28.1-1.fc28.x86_64


Note You need to log in before you can comment on or make changes to this bug.