Bug 1566044 - [OSP13] Drop runtime requirement for python-crypto (Twisted)
Summary: [OSP13] Drop runtime requirement for python-crypto (Twisted)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-twisted
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Lon Hohberger
QA Contact: Frank Jansen
URL:
Whiteboard:
Depends On:
Blocks: 1566065
TreeView+ depends on / blocked
 
Reported: 2018-04-11 12:13 UTC by Lon Hohberger
Modified: 2018-06-27 13:51 UTC (History)
5 users (show)

Fixed In Version: python-twisted-16.1.1-5.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1566058 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:50:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:51:40 UTC

Description Lon Hohberger 2018-04-11 12:13:33 UTC
Description of problem:

Python-twisted has a hard dependency on python-crypto.

* Python-crypto hasn't been maintained in years upstream.

* Every reference to python-crypto in Twisted >= 16.0.0 is in a deprecated function.

* References to python-crypto in Twisted are lazy-load imports.

* Known callers of Twisted (python-autobahn, python-txaio) do not use the deprecated functions.


Version-Release number of selected component (if applicable): python-twisted-16.1.1-5.el7ost


How reproducible: 100%

Steps to Reproduce:
1. yum install python-twisted

Actual results:
  python-crypto is installed as well


Expected results:
  python-crypto is not installed


Additional info:
  Python-crypto has not been audited for FIPS compliance.

Comment 8 errata-xmlrpc 2018-06-27 13:50:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.