Bug 1566058 - [OSP13] Drop runtime requirement for python-crypto (heat)
Summary: [OSP13] Drop runtime requirement for python-crypto (heat)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Lon Hohberger
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks: 1566065
TreeView+ depends on / blocked
 
Reported: 2018-04-11 12:43 UTC by Lon Hohberger
Modified: 2018-06-27 13:51 UTC (History)
10 users (show)

Fixed In Version: openstack-heat-10.0.1-0.20180411125639.825731d.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1566044
Environment:
Last Closed: 2018-06-27 13:50:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 13340 None queens-rdo: MERGED openstack/heat-distgit: spec: Drop python2-crypto (Ibc20850b5439476688e90ce97d05571382a55ca7) 2018-04-19 14:27:13 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:40 UTC

Description Lon Hohberger 2018-04-11 12:43:20 UTC
+++ This bug was initially created as a clone of Bug #1566044 +++

Description of problem:

openstack-heat-common has a hard dependency on python-crypto.

* As of 10.0.0.0b1, python-crypto is not required

* python-crypto hasn't been maintained in years upstream.


Version-Release number of selected component (if applicable): openstack-heat-10.0.1-0.20180404165313.825731d.el7ost


How reproducible: 100%

Steps to Reproduce:
1. yum install openstack-heat-common

Actual results:
  python-crypto is installed as well


Expected results:
  python-crypto is not installed


Additional info:
  Python-crypto has not been audited for FIPS compliance.

Comment 4 Ronnie Rasouli 2018-05-23 07:45:56 UTC
verified with openstack-heat-common-10.0.1-0.20180411125639.825731d.el7ost.noarch the python-crypto isn't installed

Comment 6 errata-xmlrpc 2018-06-27 13:50:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.