Bug 1566076 - master static pod definition using the wrong image name: ose vs ose-control-plane
Summary: master static pod definition using the wrong image name: ose vs ose-control-...
Keywords:
Status: CLOSED DUPLICATE of bug 1565442
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 13:18 UTC by Mike Fiedler
Modified: 2018-04-12 02:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-12 02:42:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1565442 0 high CLOSED master api/controller should use updated image for 3.10 2021-02-22 00:41:40 UTC

Internal Links: 1565442

Description Mike Fiedler 2018-04-11 13:18:38 UTC
Description of problem:

In 3.10.0-0.16.0 the apiserver.yaml and controller.yaml static pod definitions for the master services use:

image: registry.reg-aws.openshift.com:443/openshift3/ose:v3.10.0 

The image has been renamed and should be

image: registry.reg-aws.openshift.com:443/openshift3/ose-control-plane:v3.10.0 

Version-Release number of the following components: v3.10.0-0.16.0

How reproducible: Always

Steps to Reproduce:
1.  Install v3.10.0-0.16.0


Actual results:

In /etc/origin/node/pods/controller.yaml and /etc/origin/node/pods/apiserver.yaml

image: registry.reg-aws.openshift.com:443/openshift3/ose:v3.10.0

Expected results:

image: registry.reg-aws.openshift.com:443/openshift3/ose-control-plane:v3.10.0

Comment 1 Mike Fiedler 2018-04-12 02:42:01 UTC
Thanks @wmeng, did not see you already had a bz here.  Marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 1565442 ***


Note You need to log in before you can comment on or make changes to this bug.