Bug 1565442 - master api/controller should use updated image for 3.10
Summary: master api/controller should use updated image for 3.10
Keywords:
Status: CLOSED DUPLICATE of bug 1566814
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
: 1566076 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-10 03:02 UTC by Weihua Meng
Modified: 2018-04-16 20:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 20:02:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1566076 0 unspecified CLOSED master static pod definition using the wrong image name: ose vs ose-control-plane 2021-02-22 00:41:40 UTC

Internal Links: 1566076

Description Weihua Meng 2018-04-10 03:02:53 UTC
Description of problem:
master api/controller should use updated image for 3.10

new image (openshift3/ose-control-plane) should used instead of openshift3/ose
Version-Release number of the following components:
openshift-ansible-3.10.0-0.16.0.git.0.8925606.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. check cluster


Actual results:
# oc version
oc v3.10.0-0.16.0
kubernetes v1.9.1+a0ce1bc657
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://shared-wmengrpm3103-master-etcd-1:8443
openshift v3.10.0-0.14.0
kubernetes v1.9.1+a0ce1bc657

# oc get pods -n kube-system 
NAME                                                   READY     STATUS    RESTARTS   AGE
master-api-shared-wmengrpm3103-master-etcd-1           1/1       Running   2          1d
master-controllers-shared-wmengrpm3103-master-etcd-1   1/1       Running   2          1d
master-etcd-shared-wmengrpm3103-master-etcd-1          1/1       Running   0          1d

# oc get pods -o yaml -n kube-system | grep image:
      image: registry.reg-aws.openshift.com:443/openshift3/ose:v3.10
      image: registry.reg-aws.openshift.com:443/openshift3/ose:v3.10
      image: registry.reg-aws.openshift.com:443/openshift3/ose:v3.10
      image: registry.reg-aws.openshift.com:443/openshift3/ose:v3.10
      image: registry.access.redhat.com/rhel7/etcd
      image: registry.access.redhat.com/rhel7/etcd:latest

# cat /etc/origin/node/pods/apiserver.yaml
    image: registry.reg-aws.openshift.com:443/openshift3/ose:v3.10

Expected results:
new image (openshift3/ose-control-plane) used, as openshift3/ose is not update, latest one is v3.10.0-0.14.0.0.

See bug: https://bugzilla.redhat.com/show_bug.cgi?id=1565121

Comment 1 Mike Fiedler 2018-04-12 02:42:01 UTC
*** Bug 1566076 has been marked as a duplicate of this bug. ***

Comment 2 Scott Dodson 2018-04-16 20:02:11 UTC

*** This bug has been marked as a duplicate of bug 1566814 ***


Note You need to log in before you can comment on or make changes to this bug.