Bug 1566167 - Cannot update rawhide due to conflicts in kernel-core
Summary: Cannot update rawhide due to conflicts in kernel-core
Keywords:
Status: CLOSED DUPLICATE of bug 1564906
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-11 16:25 UTC by Milan Crha
Modified: 2018-04-11 17:22 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-11 17:22:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Milan Crha 2018-04-11 16:25:59 UTC
I tried to:

>   # dnf update

my rawhide machine today, which brought in:

>   Installing:
>    kernel                  x86_64 4.17.0-0.rc0.git4.1.fc29 rawhide   91 k
>    kernel-core             x86_64 4.17.0-0.rc0.git4.1.fc29 rawhide   25 M
>    kernel-modules          x86_64 4.17.0-0.rc0.git4.1.fc29 rawhide   28 M
>   .
>   .
>   .
>   Removing:
>    kernel                  x86_64 4.16.0-0.rc6.git1.1.fc29 @rawhide   0  
>    kernel-core             x86_64 4.16.0-0.rc6.git1.1.fc29 @rawhide  61 M
>    kernel-modules          x86_64 4.16.0-0.rc6.git1.1.fc29 @rawhide  27 M
>   Removing dependent packages:
>    kernel-modules-extra    x86_64 4.16.0-0.rc6.git1.1.fc29 @rawhide 2.2 M

but it failed with:

>   Running transaction check
>   Transaction check succeeded.
>   Running transaction test
>   The downloaded packages were saved in cache until the next successful transaction.
>   You can remove cached packages by executing 'dnf clean packages'.
>   Error: Transaction check error:
>     file /usr/share/licenses/kernel-core/COPYING from install of kernel-core-4.17.0-0.rc0.git4.1.fc29.x86_64 conflicts with file from package kernel-core-4.12.0-0.rc5.git0.1.fc27.x86_64
>     file /usr/share/licenses/kernel-core/COPYING from install of kernel-core-4.17.0-0.rc0.git4.1.fc29.x86_64 conflicts with file from package kernel-core-4.16.0-0.rc7.git1.1.fc29.x86_64

I have installed:

>   # rpm -q kernel-core
>   kernel-core-4.12.0-0.rc5.git0.1.fc27.x86_64
>   kernel-core-4.16.0-0.rc6.git1.1.fc29.x86_64
>   kernel-core-4.16.0-0.rc7.git1.1.fc29.x86_64

but I cannot remove any of those, because:

>   # dnf remove kernel-core-4.12.0-0.rc5.git0.1.fc27.x86_64 kernel-core-4.16.0-0.rc7.git1.1.fc29.x86_64
>   Error: 
>    Problem: The operation would result in removing the following protected packages: kernel-core

Thus I'm rather stuck until you fix it or you help me to fix it. Interestingly enough using:

>   # dnf update --skip-broken

doesn't help here.

Comment 1 Laura Abbott 2018-04-11 17:22:08 UTC

*** This bug has been marked as a duplicate of bug 1564906 ***


Note You need to log in before you can comment on or make changes to this bug.