Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1564906 - /usr/share/licenses/kernel-core/COPYING conflict between current and incoming kernel packages
Summary: /usr/share/licenses/kernel-core/COPYING conflict between current and incoming...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1564745 1564910 1566167 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 19:50 UTC by George R. Goffe
Modified: 2018-04-16 11:42 UTC (History)
33 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 11:42:34 UTC
Type: Bug


Attachments (Terms of Use)

Description George R. Goffe 2018-04-08 19:50:53 UTC
Description of problem:
  file /usr/share/licenses/kernel-core/COPYING from install of kernel-core-4.17.0-0.rc0.git4.1.fc29.x86_64 conflicts with file from package kernel-core-4.16.0-0.rc7.git1.1.fc29.x86_64


Version-Release number of selected component (if applicable):

see above
How reproducible:
always

Steps to Reproduce:
1.dnf upgrade
2.
3.

Actual results:
see above

Expected results:
clean and successful system upgrade

Additional info:

Comment 1 stan 2018-04-08 20:06:25 UTC
François Cami <fcami@fedoraproject.org> has found the source of the issue.  I found your bug when I was going to open a new one, so will put the information here.

The conflict existed before:
# rpm -qf /usr/share/licenses/kernel-core/COPYING
kernel-core-4.15.13-300.fc27.x86_64
kernel-core-4.15.15-300.fc27.x86_64
AFAICT the files were identical, but the content changed between f27:
d7810fab7487fb0aad327b76f1be7cd7  /usr/share/licenses/kernel-core/COPYING
and f29:
bbea815ee2795b2f4230826c0c6b8814  ./usr/share/licenses/kernel-core/COPYING
(in fact the file is completely different).

This can be traced to upstream's commit "COPYING: use the new text
with points to the license files" from 2018-03-23:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/COPYING?id=bf02d491237eea10290bd379bf7fc8c37ac6c3b4

Comment 2 Hayden 2018-04-08 23:17:28 UTC
I am experiencing this issue too.

Here is the error message:

Total                                           2.9 MB/s |  15 MB     00:05     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
file /usr/share/licenses/kernel-core/COPYING from install of kernel-core-4.17.0-0.rc0.git4.1.fc29.x86_64 conflicts with file from package kernel-core-4.16.0-0.rc7.git1.1.fc29.x86_64

Here is discussion of this issue on fedora-kernel:

https://www.spinics.net/linux/fedora/fedora-kernel/msg07127.html

Comment 3 Justin M. Forbes 2018-04-09 13:29:57 UTC
Yes, it is a known issue, just trying to figure out how to best handle it. This file changes *rarely* last change was in 2005.

Comment 4 Laura Abbott 2018-04-09 15:45:00 UTC
*** Bug 1564910 has been marked as a duplicate of this bug. ***

Comment 5 Bruno Wolff III 2018-04-09 16:03:37 UTC
*** Bug 1564745 has been marked as a duplicate of this bug. ***

Comment 6 Laura Abbott 2018-04-11 17:22:08 UTC
*** Bug 1566167 has been marked as a duplicate of this bug. ***

Comment 7 Bruno Wolff III 2018-04-12 04:33:15 UTC
This appears to be fixed in kernel-4.17.0-0.rc0.git7.1.fc29.


Note You need to log in before you can comment on or make changes to this bug.