Bug 1566225 - /usr/sbin/wrapper from kernel-bootwrapper fails during ppc64 part of Rawhide compose
Summary: /usr/sbin/wrapper from kernel-bootwrapper fails during ppc64 part of Rawhide ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: ppc64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker 1571205
TreeView+ depends on / blocked
 
Reported: 2018-04-11 19:50 UTC by Adam Williamson
Modified: 2018-11-09 13:20 UTC (History)
20 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-11-02 13:44:50 UTC


Attachments (Terms of Use)

Description Adam Williamson 2018-04-11 19:50:27 UTC
Between Fedora-Rawhide-20170406.n.0 - https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20180406.n.0/logs/ppc64/buildinstall-Everything.ppc64.log - and Fedora-Rawhide-20170407.n.0 - https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20180407.n.0/logs/ppc64/buildinstall-Everything.ppc64.log - this error started making the buildInstall compose phase for ppc64 fail:

2018-04-07 08:18:40,285: running ppc.tmpl
running ppc.tmpl
2018-04-07 08:18:48,353: command output:
/var/tmp/lorax.3lrsa69u/installroot/usr/sbin/wrapper: line 358: /scripts/file-size.sh: No such file or directory

command output:
/var/tmp/lorax.3lrsa69u/installroot/usr/sbin/wrapper: line 358: /scripts/file-size.sh: No such file or directory

2018-04-07 08:18:48,354: command returned failure (127)

The obvious thing that changed between those two dates is the kernel went from 4.17.0-0.rc0.git1.1.fc29.ppc64 to 4.17.0-0.rc0.git4.1.fc29.ppc64.

What ppc.tmpl does there is this:

    ## kernel-wrapper magic that makes the netboot combined ppc{32,64}.img
    runcmd ${inroot}/${WRAPPER} -p of \
           -D ${inroot}/${WRAPPER_DATA} \
           -i ${outroot}/${KERNELDIR}/initrd.img \
              ${outroot}/${KERNELDIR}/vmlinuz \
           -o ${outroot}/${NETIMG}

(where $WRAPPER is 'usr/sbin/wrapper' and $inroot is the installroot, in this case var/tmp/lorax.3lrsa69u/installroot ).

What kernel-wrapper does is this:

# Calculate the vmlinux.strip size
${CROSS}objcopy $objflags "$kernel" "$vmz.$$"
strip_size=$(${CONFIG_SHELL} "${srctree}/scripts/file-size.sh" "$vmz.$$")

I am not sure where $srctree is supposed to come from or what it's supposed to be, but at present it appears to be nothing at all, which could be the cause of the problem. We also can't see what it was before this broke, as it's not printed anywhere when it works, AFAICS.

Comment 1 Dan Horák 2018-04-11 19:59:18 UTC
Seems it's the right time to get rid of the wrapper thing. It was used in the ppc32 times, but shouldn't be needed any more.

The plan is roughly
- drop kernel-bootwrapper subpackage
- drop ppc64-utils metapackage (IIRC it's listed in comps)
- cleanup lorax ppc template to be 64-bit only - use ppc64le as source??

Comment 2 Dan Horák 2018-04-19 14:47:48 UTC
3rd step is done in https://github.com/weldr/lorax/pull/349

Comment 3 Dan Horák 2018-04-20 13:10:13 UTC
first part of 2nd step is https://pagure.io/fedora-comps/pull-request/270
second part will be ppc64-utils retirement

Comment 4 Adam Williamson 2018-04-25 22:36:28 UTC
note: 3rd step is not entirely 'done' till there's a Rawhide package build containing the change. I've asked bcl if he can do one.

Comment 5 Dan Horák 2018-05-15 12:59:28 UTC
an update
- lorax was built (some time ago) and composes were unblocked
- kernel spec changes from https://src.fedoraproject.org/rpms/kernel/pull-request/10 have been applied and kernel-bootwrapper will disappear in the next build

Comment 6 Dan Horák 2018-11-02 13:44:50 UTC
This cleanup has been finished in F-29.

Comment 7 IBM Bug Proxy 2018-11-09 13:20:37 UTC
------- Comment From hellerda@us.ibm.com 2018-11-09 08:11 EDT-------
After reviewing with my team we have determined that we won't need the kernel-bootwrapper package going forward.  Sorry for the false start.

Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.