Bug 1571205 - rawhide ppc64 (BE) iso do not boot after compose 20180402
Summary: rawhide ppc64 (BE) iso do not boot after compose 20180402
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: ppc64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1566225
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2018-04-24 09:58 UTC by Michel Normand
Modified: 2018-11-18 13:25 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-05-04 16:13:27 UTC


Attachments (Terms of Use)

Description Michel Normand 2018-04-24 09:58:56 UTC
Rawhide ppc64 (BE) iso do not boot after compose 20180407 (2)
Still has failure with last compose 20180419 (3)
There was no such problem with old compose 20180402 (1)

(1) https://openqa.stg.fedoraproject.org/tests/271499
(2) https://openqa.stg.fedoraproject.org/tests/275799#step/_boot_to_anaconda/2
(3) https://openqa.stg.fedoraproject.org/tests/288846#step/_boot_to_anaconda/2

The firmware  is reporting following error:

=== extract of console for 20180423 iso:
$virsh start --console rawhidebe
Domain rawhidebe started
Connected to domain rawhidebe
Escape character is ^]

SLOF **********************************************************************
QEMU Starting
 Build Date = Jun  1 2015 15:26:10
 FW Version = mockbuild@ release 20150601
 Press "s" to enter Open Firmware.

Populating /vdevice methods
Populating /vdevice/v-scsi@2000
       SCSI: Looking for devices
          8004000000000000 CD-ROM   : "QEMU     QEMU CD-ROM      2.0."
          8000000000000000 DISK     : "QEMU     QEMU HARDDISK    2.0."
Populating /vdevice/vty@30001000
Populating /vdevice/nvram@71000000
Populating /pci@800000020000000
 Adapters on 0800000020000000
                     00 0800 (D) : 106b 003f    serial bus [ usb-ohci ]
                     00 1000 (D) : 1af4 1000    virtio [ net ]
                     00 1800 (D) : 1af4 1002    unknown-legacy-device*
No NVRAM common partition, re-initializing...
Scanning USB
  OHCI: initializing
Using default console: /vdevice/vty@30001000

  Welcome to Open Firmware

  Copyright (c) 2004, 2011 IBM Corporation All rights reserved.
  This program and the accompanying materials are made available
  under the terms of the BSD License available at
  http://www.opensource.org/licenses/bsd-license.php

Trying to load:  from: /vdevice/v-scsi@2000/disk@8004000000000000 ...
E3404: Not a bootable device!
Trying to load:  from: /vdevice/v-scsi@2000/disk@8000000000000000 ... 
No DOS disk-label found.

E3404: Not a bootable device!
Trying to load:  from: HALT ... 
E3405: No such device

E3407: Load failed
===

Comment 1 Michel Normand 2018-04-24 10:00:38 UTC
I do not know what component to specify for build of iso.

Comment 2 Dan Horák 2018-04-24 10:08:27 UTC
I think this is caused by bug #1566225 and as a result the ISO doesn't have the structure and files required for booting.

Comment 3 Michel Normand 2018-04-30 08:51:57 UTC
Dan, since Rawhide  compose 20180427 we have same behavior for ppc64le (1), while it was not the case at compose 20180423 (2)

(1) https://openqa.stg.fedoraproject.org/tests/overview?distri=fedora&version=Rawhide&build=Fedora-Rawhide-20180427.n.1&groupid=3
(2) https://openqa.stg.fedoraproject.org/tests/overview?distri=fedora&version=Rawhide&build=Fedora-Rawhide-20180423.n.0&groupid=3

Comment 4 Dan Horák 2018-05-03 10:40:49 UTC
We are waiting for new lorax release and build that would contain updated templates to deal with the removed ppc64-utils meta-package :-(


Note You need to log in before you can comment on or make changes to this bug.