Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566338 - qt-creator dependencies broken after RHEL 7.5 update
Summary: qt-creator dependencies broken after RHEL 7.5 update
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt-creator
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Johansen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1577741 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 06:05 UTC by bugreports2005
Modified: 2021-07-15 08:02 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-15 08:02:03 UTC
Type: Bug


Attachments (Terms of Use)

Description bugreports2005 2018-04-12 06:05:16 UTC
RHEL 7.5 updates qt5 from 5.6.2 to 5.9.2, leaving some Qt-related packages in EPEL uninstallable. If already installed, the entire system upgrade can get blocked.

As far as qt-creator is concerned, these dependencies seem relevant:

qt-creator-4.1.0-3.el7.x86_64   requires qt5-qtbase(x86-64) = 5.6.2
qt5-qtwebkit-5.6.2-1.el7.x86_64 requires qt5-qtbase(x86-64) = 5.6.2
qt5-qtwebkit-5.6.2-1.el7.x86_64 requires qt5-qtdeclarative(x86-64) = 5.6.2

In addition there's at least this, but there are probably more.

qt5-qtquick1-5.6.2-1.64faeb0git.el7.x86_64 requires qt5-qtbase(x86-64) = 5.6.2

Comment 1 Itamar Reis Peixoto 2018-04-20 00:13:14 UTC
It needs to be recompiled against new libs, you can send an email to the people listed here ->  

https://src.fedoraproject.org/rpms/qt-creator/blob/epel7/f/qt-creator.spec

Comment 2 Anssi Johansson 2018-05-14 05:52:19 UTC
A new qt5-qtwebkit is already available in epel-testing, see bug 1572156. Same for qt5-qtquick1, bug 1576820.

The qt-creator issue still remains, though.

Comment 3 Rex Dieter 2018-05-14 12:22:53 UTC
*** Bug 1577741 has been marked as a duplicate of this bug. ***

Comment 4 bugreports2005 2021-07-15 08:02:03 UTC
This isn't current anymore.


Note You need to log in before you can comment on or make changes to this bug.