Bug 1566398 - Heketi is not doing rebalance after expanding volume
Summary: Heketi is not doing rebalance after expanding volume
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.10
Assignee: Michael Adam
QA Contact: Nitin Goyal
URL:
Whiteboard:
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-04-12 08:57 UTC by Nitin Goyal
Modified: 2018-09-12 09:23 UTC (History)
10 users (show)

Fixed In Version: heketi-6.0.0-13.el7rhg
Doc Type: Bug Fix
Doc Text:
Previously, a rebalance operation was not run after expanding a volume in Heketi. This meant that only new files could be written to newly added space. With this fix, Heketi performs a rebalance operation on the volume after expansion.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
heketi logs (14.73 KB, text/plain)
2018-04-12 08:57 UTC, Nitin Goyal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github heketi/heketi/commit/d54452104da3fe243279316977135e635550cbff 0 None None None 2020-06-01 10:12:58 UTC
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:14 UTC

Description Nitin Goyal 2018-04-12 08:57:10 UTC
Created attachment 1420758 [details]
heketi logs

Description of problem: I have expand one volume, but data is written only on first replica pair.


Version-Release number of selected component (if applicable): 6.0.0.10


How reproducible:


Steps to Reproduce:
1. Create one volume.
2. Mount it on client.
3. Write some files.
4. Expand the size of volume.
5. Write some files.

Actual results: It is not doing rebalance, because of that files are written on only first replica pair.


Expected results: It should do rebalance. So data will write on all replica pairs.


Additional info:

Comment 8 Anjana KD 2018-08-30 14:24:17 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 9 John Mulligan 2018-09-07 17:58:10 UTC
Doc Text looks OK

Comment 11 errata-xmlrpc 2018-09-12 09:22:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.