Bug 15664 - Beta 5 Xconfigurator and i810 Video.
Beta 5 Xconfigurator and i810 Video.
Status: CLOSED DUPLICATE of bug 16296
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Winston rc1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 13:03 EDT by Rogelio Noriega
Modified: 2014-03-16 22:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 16:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rogelio Noriega 2000-08-07 13:03:48 EDT
Dell Optiplex GX100/GX110
i810 Chip set.
Xconfigurator 4.3.38-1, 4.3.35-1, and 4.3.40-1.

If 1MB VRAM is selected, 640x480 24bpp works, but nothing in 16bpp works
in any case.  Xconfigurator may crash on exit, leaving a
black screen and a mouse.  If it does not crash, the mouse will still
remain in the terminal and usually cause erratic highlighting and
return characters when moved (without pressing any buttons).
The mouse is set to generic PS/2 whereas there was a MS Intellimouse
attached.  Setting it to Intellimouse does not fix this problem.

At 1MB, choosing 16bpp causes "there is something wrong with the
X configuration" error.  If 16bpp ever works in Xconfigurator,
it causes a crash of X with the drm library claimed to be at version
1.1.0 and expected 1.0.x.
This was with a Dell D1025TM Trinitron monitor.

4MB is the proper VRAM setting but Xconfigurator defaulted to 1.  At 4MB I 
tested the config.  
Picking a single or multiple modes in 8 or 24bpp worked fine.  If at least 
5 modes were
selected 16bpp worked and all modes were workable (switched with ctrl-alt-
arrow).  If any less
were selected, Xconfigurator would say that there was something wrong with 
the Xconfiguration.
In addition, the size of the virtual desktop was 1280x1024 under these 
modes.  Picking other modes, 
the desktop was the size of the screen.
Comment 1 Trond Eivind Glomsrxd 2000-08-08 10:36:44 EDT
We have the hardware, will check.
Comment 2 Glen Foster 2000-08-08 11:21:42 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 3 Trond Eivind Glomsrxd 2000-08-08 11:34:50 EDT
The "cant start X multiple times" issue is an XFree86 issue, as is the drm. When
it comes to memory, this is what i810 returns to kudzu. Reassigning to Bill.
Comment 4 Trond Eivind Glomsrxd 2000-08-10 11:24:56 EDT
Please use RC 1 and an updated d Xconfigurator 4.3.45 from
http://people.redhat.com/teg/xc/ - this fixes the problem here.
Comment 5 Rogelio Noriega 2000-08-16 14:27:08 EDT
Video is working but, can not be set to 24 bit 1600x1200 it will automatically 
defaults back to 1280x1024.
Comment 6 Trond Eivind Glomsrxd 2000-08-16 14:30:20 EDT
Try specifying 32 MB...
Comment 7 Trond Eivind Glomsrxd 2000-08-16 14:39:55 EDT
OK - verified. Just tell it "32 MB" and it will work. It uses a bit more memory
since 3D is enabled, which is why this resolution is shown but doesn't work.
Comment 8 Rogelio Noriega 2000-08-16 14:44:44 EDT
I should have added that to the bug we did try 32 meg and it failed.
Comment 9 Trond Eivind Glomsrxd 2000-08-16 15:00:26 EDT
Hmm... I'll look into that. Right now, that machine is busy installing.
Reopening so I don't forget it....

BTW: Tried increasing the number in the file even more, manually?
Comment 10 Trond Eivind Glomsrxd 2000-08-16 16:20:52 EDT
Hmmm... it segfaults in 24bpp 1600x1200 now.
Comment 11 Bill Nottingham 2000-08-18 17:11:49 EDT

*** This bug has been marked as a duplicate of 16296 ***

Note You need to log in before you can comment on or make changes to this bug.