Bug 16296 - Xconfigurator limited on i815
Xconfigurator limited on i815
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 15664 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 17:22 EDT by Yu-Pa Ng
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-03 04:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Startx error message when trying 16 bit 1600x1200 (7.60 KB, text/plain)
2000-08-15 17:25 EDT, Yu-Pa Ng
no flags Details
X configuration file (1.39 KB, text/plain)
2000-08-25 14:43 EDT, Yu-Pa Ng
no flags Details

  None (edit)
Description Yu-Pa Ng 2000-08-15 17:22:52 EDT
Xconfigurator on Dell Optiplex GX150 with onboard Intel i815 chipset video 
has limited resolution.  The highest resolution for 16 bit is 1280 x 1024,
and for 24 bit is 1024 x 768, regardless if I set VideoRam 16384 or 32768.
Comment 1 Yu-Pa Ng 2000-08-15 17:25:40 EDT
Created attachment 2524 [details]
Startx error message when trying 16 bit 1600x1200
Comment 2 Trond Eivind Glomsrxd 2000-08-15 18:26:39 EDT
Are you saying that Xconfigurator doesn't give higher alternatives or that
higher modes won't work?
Comment 3 Trond Eivind Glomsrxd 2000-08-16 11:42:41 EDT
Tried telling you have 32 MB of memory?
Comment 4 Yu-Pa Ng 2000-08-16 14:38:49 EDT
16 bit 1600x1200 will work only if VideoRam is set to 32768.
8  bit 1600x1200 will work with VideoRam of 8192 or 16384, but will not 
   work when VideoRam is set to 32768.
24 bit will not work if VideoRam is set to 32768.  Under Xconfigurator,
   we set VideoRam to 16384 with 1600x1200.  It automatically defaults back to
   1280x1024 and the screen quality is shakey, jittery with vertical lines.
Comment 5 Trond Eivind Glomsrxd 2000-08-16 14:42:36 EDT
See #15664  - with 3D support enabled, it uses more memory so you need to enable
the 32 MB. As for the screen quality, I'll be happy to blame a cheapish on-board
chipset - it'll hardly be dimensioned for running 1600x1200.... Does you know if
it works better in Windows or if using a better monitor helps?
Comment 6 Yu-Pa Ng 2000-08-17 13:26:29 EDT
I don't know if it works better in Windows.  We tried a better monitor.  It did 
not help.
Comment 7 Bill Nottingham 2000-08-17 14:02:24 EDT
32MB seems to break 24bpp operation completely. We haven't
determined exactly why yet.
Comment 8 Bill Nottingham 2000-08-18 17:11:47 EDT
*** Bug 15664 has been marked as a duplicate of this bug. ***
Comment 9 Yu-Pa Ng 2000-08-21 17:36:15 EDT
RC2 has the same problem.
Comment 10 Bill Nottingham 2000-08-21 17:38:59 EDT
Yes. It appears to be a driver bug.
Comment 11 Yu-Pa Ng 2000-08-25 14:36:18 EDT
When running 1024x768 on 16 bit depth on KDE, the screen flashes a few times 
during the logon.  Once logged on, it is fine.  Plese see the attachment file 
XF86Config-4.
Comment 12 Yu-Pa Ng 2000-08-25 14:43:26 EDT
Created attachment 3003 [details]
X configuration file
Comment 13 Yu-Pa Ng 2000-09-06 14:57:20 EDT
This happens on Dell Optiplex GX110 with Intel i810e chipset as well.
     "When running 1024x768 on 16 bit depth on KDE, the screen flashes a few 
times during the logon.  Once logged on, it is fine.  Plese see the attachment 
file XF86Config-4. "
Comment 14 Mike A. Harris 2001-05-25 10:02:01 EDT
Does this problem still occur in Red Hat Linux 7.1 with XFree86-4.0.3?
Comment 15 Mike A. Harris 2001-05-25 10:15:48 EDT
Looking at the log again, your log indicates DRM could not allocate DMA
buffers.  You can only use DRI on Intel i81x hardware in depth 16, and you
cannot use high res and DRI simultaneously without a large amount of RAM.

In general, take the amount of memory given in your config, divide that by
4, and the remainder is what is available for 2D when DRI is enabled.  So 16Mb
would leave you with 4Mb.

"man i810" gives configuration fine tuning details.

If you configure with:

Xconfigurator --preferxf4 --nodri

Does it solve the problem?
Comment 16 Mike A. Harris 2001-06-12 02:30:24 EDT
Have you tried the information I supplied?  If so, did it change anything
for you at all?
Comment 17 Mike A. Harris 2001-07-03 04:26:56 EDT
Please respond to my comments from 2001-05-25 onward so I can track if the
new releases have fixed this or not.

Thanks.

Comment 18 Rogelio Noriega 2001-07-31 10:41:52 EDT
Fixed in 7.0 sbe

Note You need to log in before you can comment on or make changes to this bug.