Bug 1566719 - [RFE] Remove OpenStack and Ceph packages from overcloud images by default
Summary: [RFE] Remove OpenStack and Ceph packages from overcloud images by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-puppet-elements
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: Upstream M2
: 14.0 (Rocky)
Assignee: Alex Schultz
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1491796 (view as bug list)
Depends On:
Blocks: 1615696
TreeView+ depends on / blocked
 
Reported: 2018-04-12 20:49 UTC by Alex Schultz
Modified: 2019-01-11 11:49 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-puppet-elements-9.0.0-0.20180531174540.cb18bc8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 11:49:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1767135 0 None None None 2018-04-26 15:21:09 UTC
OpenStack gerrit 563608 0 None MERGED Remove Openstack and Ceph packages attempt 2 2020-02-18 10:27:03 UTC
OpenStack gerrit 564531 0 None MERGED Add keepalived back 2020-02-18 10:27:03 UTC
OpenStack gerrit 567240 0 None MERGED Additional OpenStack cleanup 2020-02-18 10:27:04 UTC
Red Hat Product Errata RHEA-2019:0045 0 None None None 2019-01-11 11:49:53 UTC

Description Alex Schultz 2018-04-12 20:49:45 UTC
As we move to containers and in an end goal to achieve Bug 1484962, we should not install the openstack and ceph service related rpms in the overcloud image building process.

Current situtation:
All openstack and ceph services rpms are still included in overcloud images even though they are being run via containers.

Expected result:
1) overcloud-full.qcow2 should not contain openstack & ceph service RPMs.
2) OpenstackClient related RPMs may still be installed (TBD)

Comment 4 Mike Burns 2018-07-13 18:24:06 UTC
*** Bug 1491796 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2019-01-11 11:49:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045


Note You need to log in before you can comment on or make changes to this bug.