Bug 1566732 - EIO errors on some operations when volume has mixed brick versions on a disperse volume
Summary: EIO errors on some operations when volume has mixed brick versions on a dispe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1569403 1569405 1569407 1569409 1569457
TreeView+ depends on / blocked
 
Reported: 2018-04-12 21:30 UTC by Xavi Hernandez
Modified: 2018-06-20 18:04 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1569403 1569405 1569407 1569409 1569457 (view as bug list)
Environment:
Last Closed: 2018-06-20 18:04:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2018-04-12 21:30:29 UTC
Description of problem:

If a disperse volume has different brick versions, some operations done on the volume will generate EIO errors.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-04-12 21:35:07 UTC
REVIEW: https://review.gluster.org/19861 (libglusterfs: fix comparison of a NULL dict with a non-NULL dict) posted (#1) for review on master by Xavi Hernandez

Comment 2 Worker Ant 2018-04-18 12:23:19 UTC
COMMIT: https://review.gluster.org/19861 committed in master by "Xavi Hernandez" <xhernandez@redhat.com> with a commit message- libglusterfs: fix comparison of a NULL dict with a non-NULL dict

Function are_dicts_equal() had a bug when the first argument was NULL and
the second one wasn't NULL. In this case it incorrectly returned that the
dicts were different when they could be equal.

Fixes: bz#1566732
Change-Id: I0fc245c2e7d1395865a76405dbd05e5d34db3273
Signed-off-by: Xavi Hernandez <xhernandez@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:04:29 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.