Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1569403 - EIO errors on some operations when volume has mixed brick versions on a disperse volume
Summary: EIO errors on some operations when volume has mixed brick versions on a dispe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On: 1566732
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 08:51 UTC by Xavi Hernandez
Modified: 2018-05-07 15:15 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1566732
Environment:
Last Closed: 2018-05-07 15:15:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Xavi Hernandez 2018-04-19 08:51:52 UTC
+++ This bug was initially created as a clone of Bug #1566732 +++

Description of problem:

If a disperse volume has different brick versions, some operations done on the volume will generate EIO errors.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-04-19 09:01:30 UTC
REVIEW: https://review.gluster.org/19906 (libglusterfs: fix comparison of a NULL dict with a non-NULL dict) posted (#1) for review on release-4.0 by Xavi Hernandez

Comment 2 Worker Ant 2018-04-24 12:52:31 UTC
COMMIT: https://review.gluster.org/19906 committed in release-4.0 by "Xavi Hernandez" <xhernandez@redhat.com> with a commit message- libglusterfs: fix comparison of a NULL dict with a non-NULL dict

Function are_dicts_equal() had a bug when the first argument was NULL and
the second one wasn't NULL. In this case it incorrectly returned that the
dicts were different when they could be equal.

backport of:
> BUG: 1566732

BUG: 1569403
Change-Id: I0fc245c2e7d1395865a76405dbd05e5d34db3273
Signed-off-by: Xavi Hernandez <xhernandez@redhat.com>

Comment 3 Shyamsundar 2018-05-07 15:15:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.2, please open a new bug report.

glusterfs-4.0.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-April/000097.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.