Bug 1566924 - short name of serviceinstances.servicecatalog.k8s.io and serviceinbindings.servicecatalog.k8s.io are replaced by *.automationbroker.io
Summary: short name of serviceinstances.servicecatalog.k8s.io and serviceinbindings.se...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Shawn Hurley
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks: 1550418
TreeView+ depends on / blocked
 
Reported: 2018-04-13 07:44 UTC by Zihan Tang
Modified: 2018-07-30 19:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:33 UTC

Description Zihan Tang 2018-04-13 07:44:11 UTC
Description of problem:
oc get serviceinstance and servicebinding can not list out result of serviceinstances.servicecatalog.k8s.io and serviceinbindings.servicecatalog.k8s.io

the short name of 'serviceinstance' and 'servicebindings' are replaced by serviceinstances.automationbroker.io and servicebindings.automationbroker.io


Version-Release number of selected component (if applicable):
asb 1.2.5
service catalog : v0.1.13

How reproducible:
always

Steps to Reproduce:
1. provision postgresql-apb in test project , and create a binding
2. oc get serviceinstance -n test, oc get servicebinding -n test

Actual results:
can not listout the serviceinstance and servicebinding
[root@host-172-16-120-84 ~]# oc get serviceinstance.servicecatalog.k8s.io -n test
NAME                      AGE
rh-postgresql-apb-krfjn   12m
[root@host-172-16-120-84 ~]# oc get serviceinstance -n test
No resources found.

[root@host-172-16-120-84 ~]# oc get servicebindings.servicecatalog.k8s.io -n test
NAME                            AGE
rh-postgresql-apb-krfjn-fl877   13m
[root@host-172-16-120-84 ~]# oc get servicebindings -n test
No resources found.

the short name for *.automationbroker.io 
[root@host-172-16-120-84 ~]# oc get serviceinstances -n openshift-ansible-service-broker
NAME                                   AGE
3fe7376c-3ee0-11e8-a8d4-0a580a80000b   15m
[root@host-172-16-120-84 ~]# oc get servicebindings -n openshift-ansible-service-broker
NAME                                   AGE
53d81450-3ee0-11e8-a8d4-0a580a80000b   14m

Expected results:
the short name of 'serviceinstance' and servicebindings are still for *.servicecatalog.k8s.io

it's better to use different short name for broker's CDs and service catalog objects 
Additional info:

Comment 1 Zihan Tang 2018-04-25 02:46:13 UTC
Because most of auto test use `serviceinstance` and `servicebinding` to check service catalog objects , so add 'TestBlocker' tag .

Comment 2 Zihan Tang 2018-04-26 05:42:14 UTC
Shawn, 
what's the status of this bug,  will you update the crds ?

Comment 3 Shawn Hurley 2018-04-26 12:20:12 UTC
I am working on PRs for this now:
https://github.com/automationbroker/broker-client-go/pull/7
https://github.com/automationbroker/bundle-lib/pull/62
https://github.com/openshift/ansible-service-broker/pull/907

I will be working on getting this merged today

Comment 6 David Zager 2018-04-27 20:15:58 UTC
PRs have been merged and the ansible-service-broker package, version 1.2.8-1 released downstream.

Comment 7 Zihan Tang 2018-05-02 02:42:12 UTC
Shawn, openshit-ansible PR : https://github.com/openshift/ansible-service-broker/pull/895 
has not been merged, so we can not test asb 1.2.8 related bugs because it can not find refined crds.
please help merged the ansible prs.

Comment 9 Zihan Tang 2018-05-04 05:56:23 UTC
The latest ansible version is 3.10.0-0.32.0, not include this ansible PR.  ASB bugs fixed in v1.2.8+ will be blocked until the new ansible release is ready.

Comment 10 Zihan Tang 2018-05-07 07:26:51 UTC
image is ready , so change it to ON_QA.

Comment 11 Zihan Tang 2018-05-07 07:30:15 UTC
verified , 
openshift-ansible : v3.10.0-0.35.0.0

[root@host-172-16-120-56 tmp]# oc get serviceinstance -n test
NAME                      AGE
rh-postgresql-apb-d6vfr   10m
[root@host-172-16-120-56 tmp]# oc get servicebinding -n test
NAME                            AGE
rh-postgresql-apb-d6vfr-57vrl   1m

but the crd are not created as expected in installation , create another bug 1575508 to trace it.

Comment 13 errata-xmlrpc 2018-07-30 19:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.