Bug 1567025 - Pods pending due to node does not have label "node-role.kubernetes.io/compute=true" in all-in-one cluster
Summary: Pods pending due to node does not have label "node-role.kubernetes.io/compute...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Vadim Rutkovsky
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks: 1567028
TreeView+ depends on / blocked
 
Reported: 2018-04-13 10:05 UTC by Weihua Meng
Modified: 2018-07-30 19:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1567028 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:12:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:33 UTC

Description Weihua Meng 2018-04-13 10:05:23 UTC
Description of problem:
Pods pending due to node does not have label "node-role.kubernetes.io/compute=true" in all-in-one cluster

Version-Release number of the following components:
openshift-ansible-3.10.0-0.21.0.git.0.0b1d180.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. deploy OCP all-in-one cluster
2. check pods status and node labels

Actual results:
pod in pending status due to 
"Node-Selectors:  node-role.kubernetes.io/compute=true"

This is default in master-config
projectConfig:
  defaultNodeSelector: node-role.kubernetes.io/compute=true

# oc get node --show-labels
NAME                       STATUS    ROLES     AGE       VERSION             LABELS
qe-wmengrpm310a1-merrn-1   Ready     master    4h        v1.10.0+b81c8f8   beta.kubernetes.io/arch=amd64,beta.kubernetes.io/instance-type=n1-highmem-4,beta.kubernetes.io/os=linux,failure-domain.beta.kubernetes.io/region=us-central1,failure-domain.beta.kubernetes.io/zone=us-central1-a,kubernetes.io/hostname=qe-wmengrpm310a1-merrn-1,node-role.kubernetes.io/master=true,registry=enabled,role=node,router=enabled

Expected results:
at least one node should have the label match default node selector.
node should have node-role.kubernetes.io/compute=true label in all-in-one cluster.

Comment 1 Vadim Rutkovsky 2018-04-13 11:34:07 UTC
Created https://github.com/openshift/openshift-ansible/pull/7945 to fix this

Comment 2 Jan Pazdziora 2018-04-13 13:05:34 UTC
With Origin, we see the problem with 3.9 as well: https://github.com/openshift/openshift-ansible/issues/7833. For OCP, is this isolated to 3.10 only?

Comment 3 Vadim Rutkovsky 2018-04-13 14:23:38 UTC
(In reply to Jan Pazdziora from comment #2)
> With Origin, we see the problem with 3.9 as well:
> https://github.com/openshift/openshift-ansible/issues/7833. For OCP, is this
> isolated to 3.10 only?

see https://bugzilla.redhat.com/show_bug.cgi?id=1567028

Comment 4 Vadim Rutkovsky 2018-04-17 08:34:37 UTC
Fix is in openshift-ansible-3.10.0-0.22.0

Comment 5 Weihua Meng 2018-04-17 15:24:54 UTC
Fixed.
openshift-ansible-3.10.0-0.22.0.git.0.b6ec617.el7

app pods running.

Comment 7 errata-xmlrpc 2018-07-30 19:12:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.