Bug 1567028 - [3.9]Pods pending due to node does not have label "node-role.kubernetes.io/compute=true" in all-in-one cluster
Summary: [3.9]Pods pending due to node does not have label "node-role.kubernetes.io/co...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Vadim Rutkovsky
QA Contact: Weihua Meng
URL:
Whiteboard:
: 1563399 (view as bug list)
Depends On: 1567025
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 10:07 UTC by Weihua Meng
Modified: 2018-05-17 06:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1567025
Environment:
Last Closed: 2018-05-17 06:43:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:44:33 UTC

Description Weihua Meng 2018-04-13 10:07:04 UTC
+++ This bug was initially created as a clone of Bug #1567025 +++

Description of problem:
Pods pending due to node does not have label "node-role.kubernetes.io/compute=true" in all-in-one cluster

Version-Release number of the following components:
openshift-ansible-3.10.0-0.21.0.git.0.0b1d180.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. deploy OCP all-in-one cluster
2. check pods status and node labels

Actual results:
pod in pending status due to 
"Node-Selectors:  node-role.kubernetes.io/compute=true"

This is default in master-config
projectConfig:
  defaultNodeSelector: node-role.kubernetes.io/compute=true

# oc get node --show-labels
NAME                       STATUS    ROLES     AGE       VERSION             LABELS
qe-wmengrpm310a1-merrn-1   Ready     master    4h        v1.10.0+b81c8f8   beta.kubernetes.io/arch=amd64,beta.kubernetes.io/instance-type=n1-highmem-4,beta.kubernetes.io/os=linux,failure-domain.beta.kubernetes.io/region=us-central1,failure-domain.beta.kubernetes.io/zone=us-central1-a,kubernetes.io/hostname=qe-wmengrpm310a1-merrn-1,node-role.kubernetes.io/master=true,registry=enabled,role=node,router=enabled

Expected results:
at least one node should have the label match default node selector.
node should have node-role.kubernetes.io/compute=true label in all-in-one cluster.

Comment 1 Scott Dodson 2018-04-13 12:21:12 UTC
*** Bug 1563399 has been marked as a duplicate of this bug. ***

Comment 5 Weihua Meng 2018-04-20 10:20:07 UTC
Fixed.
openshift-ansible-3.9.24-1.git.0.d0289ea.el7

compute role added.
# oc get nodes
NAME                     STATUS    ROLES            AGE       VERSION
qe-wmeng39a1de-merrn-1   Ready     compute,master   31m       v1.9.1+a0ce1bc657

all custom pods running

  Operating System: Red Hat Enterprise Linux Server 7.5 (Maipo)
       CPE OS Name: cpe:/o:redhat:enterprise_linux:7.5:GA:server
            Kernel: Linux 3.10.0-862.el7.x86_64

Comment 8 errata-xmlrpc 2018-05-17 06:43:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.