Bug 1567206 - grub2 / grub2-mkconfig does not create menuentry for existing systems on other partitions, lacks os-prober dependency
Summary: grub2 / grub2-mkconfig does not create menuentry for existing systems on othe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-13 14:51 UTC by Lawrence Lowe
Modified: 2018-05-25 09:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-25 09:09:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Lawrence Lowe 2018-04-13 14:51:37 UTC
Description of problem:

The grub.cfg created as a result of a fresh installation of Fedora 28 Beta on a spare MBR partition does not have a menuentry for systems on other partitions, such as other Linux and Windows systems. Running grub2-mkconfig from within the new system yields the same result.

Version-Release number of selected component (if applicable):

grub2 2.02-29.fc28 in Fedora 28 Beta

How reproducible:

Always

Steps to Reproduce:
1. Copy a Fedora 28 beta Workstation netinstall 64-bit image to a memory stick
2. Boot the memory stick on a workstation (BIOS and MBR partitioned disk)
3. Request install of a minimal system or a full Fedora Workstation (doesn't matter) onto a spare partition on the workstation.
4. Reboot installed system. 

Actual results:

Observe that only the newly-installed system and its rescue entry are listed in the offered grub menu. Running grub2-mkconfig a further time within the installed system is no help, it produces the same grub.cfg.

Expected results:

Expect that in addition to the newly installed system, other pre-existing Fedora systems and Windows systems on other partitions will also have menuentry(s) and be bootable

Additional info:

Comment 1 Lawrence Lowe 2018-04-19 14:52:22 UTC
This issue can be circumvented post-installation by installing the os-prober package and then re-running grub2-mkconfig -o /boot/grub2/grub.cfg .

Doing a rpm --query --requires for each of the grub2 2.02-29.fc28 packages shows no declared dependency on the os-prober package. This seems to be similar to the 2011 bug #678456. 

I've added to the summary title of this bug to reflect this additional info.

Comment 2 Lawrence Lowe 2018-05-25 09:09:27 UTC
Issue satisfactorily fixed by release of grub2 2.02-34 on 2018-04-23 which re-instated os-prober dependency.


Note You need to log in before you can comment on or make changes to this bug.