Bug 1567418 - Cannot put special characters in proxy password in Advanced Config
Summary: Cannot put special characters in proxy password in Advanced Config
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: GA
: 5.10.0
Assignee: Jason Frey
QA Contact: Jaroslav Henner
URL:
Whiteboard:
Depends On:
Blocks: 1568467
TreeView+ depends on / blocked
 
Reported: 2018-04-13 23:39 UTC by David Luong
Modified: 2019-08-22 00:54 UTC (History)
9 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1568467 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:04:01 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description David Luong 2018-04-13 23:39:22 UTC
Description of problem:
Cannot put special characters in proxy password in Advanced Config

Version-Release number of selected component (if applicable):
5.9.1

How reproducible:
Everytime

Steps to Reproduce:
1.  Have a password with a special character like ? in it
2.  Save and try to add provider
3.  

Actual results:
This shows up when trying to validate:
"Credential validation was not successful: Unexpected response returned from system: 407 "Proxy Authentication Required"


Expected results:
Provider added successfully

Additional info:

Comment 5 Joe Rafaniello 2018-04-17 14:09:55 UTC
Note, while testing this fix, we found that we ran into the similar/duplicate bug 1559019 and bug 1552114.  Those bugs caused our http proxy settings for a "new" (unsaved) provider to be ignored, leading to a 407 "Proxy Authentication Required" error.  Thankfully, David found the above bugs and their fixes and we were able to verify they worked in combination with the changes below.

Therefore, we needed the hotfix for the above bugs in order to test:
1) Jason's original PR on the aws-sdk-ruby gem: https://github.com/aws/aws-sdk-ruby/pull/1760.  This will hopefully be merged and released and be the eventual longterm fix.

2) Until that gem is fixed, released and we can update to it, we'll patching the method via the PR from Nick:
https://github.com/ManageIQ/manageiq-providers-amazon/pull/432

Comment 7 Matouš Mojžíš 2018-11-14 15:55:34 UTC
Verified in 5.10.0.23. Tried to add ec2 provider through squid proxy where password contained "?" and it was successful.


Note You need to log in before you can comment on or make changes to this bug.