Bug 1567893 - Can't browse to the properties tab if the Cinder NetApp backend is enabled
Summary: Can't browse to the properties tab if the Cinder NetApp backend is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z2
: 13.0 (Queens)
Assignee: Alan Bishop
QA Contact: Avi Avraham
URL:
Whiteboard:
: 1581070 (view as bug list)
Depends On:
Blocks: 1492728
TreeView+ depends on / blocked
 
Reported: 2018-04-16 11:35 UTC by Udi
Modified: 2018-12-24 11:40 UTC (History)
14 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.4-3.el7ost
Doc Type: Bug Fix
Doc Text:
TripleO's capabilities-map.yaml referenced Cinder's Netapp backend in an incorrect file location. The UI uses the capabilities map and was unable to access Cinder's Netapp configuration file. The capabilities-map.yaml has been updated to specify the correct location for Cinder's Netapp configuration. The UI's properties tab for the Cinder Netapp backend functions correctly.
Clone Of:
Environment:
Last Closed: 2018-08-29 16:35:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1769639 None None None 2018-05-07 12:12:10 UTC
OpenStack gerrit 566566 None master: MERGED tripleo-heat-templates: Clean up Cinder backends in capabilities map (Ic5266abcafed5790296fd910b01aadf3d03900b5) 2018-07-19 01:40:08 UTC
OpenStack gerrit 568397 None stable/queens: MERGED tripleo-heat-templates: Clean up Cinder backends in capabilities map (Ic5266abcafed5790296fd910b01aadf3d03900b5) 2018-07-19 01:40:01 UTC
Red Hat Product Errata RHBA-2018:2574 None None None 2018-08-29 16:36:16 UTC

Description Udi 2018-04-16 11:35:22 UTC
Description of problem:
If you enable some of the Cinder backends in your environment, and save and move over to the "Properties" tab, you get this:

Deployment parameters could not be loaded
404 Client Error: Not Found for url: https://192.168.24.2:13808/v1/AUTH_d89c3add038047b0b4bedc6bebe43c87/overcloud/puppet/extraconfig/pre_deploy/controller/cinder-netapp.yaml


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Open the plan configuration dialog
2. In the "Storage" section, enable the Cinder NetApp backend
3. Save
4. Click on the "Properties" tab


Actual results:
Error: Deployment parameters could not be loaded


Additional info:
This happens with several other Cinder environment files as well.

Comment 2 Jiri Tomasek 2018-04-25 11:40:05 UTC
The error occurs because https://github.com/openstack/tripleo-heat-templates/blob/master/environments/storage/cinder-netapp-config.yaml environment points to non-existent ../../puppet/extraconfig/pre_deploy/controller/cinder-netapp.yaml template from resource_registry.

This makes the environment unusable. The environment needs to get updated or removed and removed from capabilities-map.yaml in tripleo-heat-templates.

Comment 4 Alan Bishop 2018-05-02 16:57:32 UTC
This goes deeper than I thought. Yes, the problem is triggered by
environments/storage/cinder-netapp-config.yaml not being updated to reflect
changes made to support composable roles And I traced things further to the
sample config generator's input [1].

[1] https://github.com/openstack/tripleo-heat-templates/blob/master/sample-env-generator/storage.yaml#L139

I can easily solve the problem for NetApp, but looking around in that file I
see bigger issues. The Ceph backends are still referencing puppet-ceph
templates, which are only valid through Ocata. This has me questioning whether
the generated config files are suitable for current releases.

Ben, can you comment on this?

Comment 5 Ben Nemec 2018-05-04 14:53:21 UTC
The generated storage environments were originally intended as a PoC for the environment generator tool.  The intent was that they would eventually replace all of the hand-written environments and become the primary way to enable features.  That obviously hasn't happened.

Since they're evidently not being maintained, I'd be inclined to say just remove them and point back at the hand-written files.  I still think all environments should be generated, but I've had limited success convincing upstream of that and I don't intend to pursue it further.

Comment 6 Alan Bishop 2018-05-04 15:01:56 UTC
Thanks, Ben!

So it seems the UI should not be using generated environment files such as tht/environments/storage/cinder-netapp-config.yaml. Reassigning back to UI team.

Comment 7 Udi 2018-05-06 06:15:49 UTC
What's a generated environment file, and how do we know if a file is such? Is there a way to prevent users (CLI users as well as UI users) from enabling those unmaintained files? Won't it be simpler to remove them if they don't work anyways?

Comment 8 Jiri Tomasek 2018-05-07 07:46:11 UTC
Udi, Ben has created a tool which generates environment files based on input files. This tool ensures, that all necessary information is provided in the generated environment files. I really value this as it gives us a validation that when an environment is introduced, it is produced in a form which is consumable by UI and includes proper information. Also as part of Ben's effort, the environments were nicely organized in environments directory. It is quite a pity that it is not being used by upstream.

Alan, TripleO-UI is listing environments and taking information from capabilities-map.yaml which is included in tripleo-heat-templates repository. This file contains all necessary metadata about environments, so GUI can guide user through the large amount of environments currently available and provide as much information as possible.

IMHO it should be a responsibility of each DFG to update capabilities-map.yaml when an environment is addded/updated to THT. This ensures, that GUI lets user use up to date environments and description and other metadata are up to date.

It is not possible for UI DFG to keep up with the amount of environment files currently available in tripleo-heat-templates and understand what features these environments enable. Could you please verify that the Storage section in capabilities-map.yaml is up to date and includes all features (environments) which are currently available?

The benefit of TripleO UI in this sense is that there is no need to introduce additional code to support certain feature in UI. All that is needed is that environment file is properly defined and metadata provided in capabilities-map.yaml.

Comment 9 Alan Bishop 2018-05-07 11:55:41 UTC
I forgot that the UI is keying off the capabilities map, and yes, the Storage DFG is responsible for the storage entries.

Comment 10 Alan Bishop 2018-05-14 23:42:06 UTC
Merged on upstream master, proposed to stable/queens.

Comment 12 Alan Bishop 2018-05-23 14:12:16 UTC
*** Bug 1581070 has been marked as a duplicate of this bug. ***

Comment 22 Tzach Shefi 2018-08-02 14:37:59 UTC
Udi, 
Need help getting access/deploying a system with UI. 
Can you point to me to some docs or contact person for this?

Comment 23 Avi Avraham 2018-08-12 08:39:41 UTC
Verified,
package version 
openstack-tripleo-heat-templates-8.0.4-10.el7ost.noarch
Parameters updated from UI and been updated to plan-environment.yaml file

Comment 25 errata-xmlrpc 2018-08-29 16:35:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2574


Note You need to log in before you can comment on or make changes to this bug.