Bug 1567921 - libmodulemd emits modulemd-defaults with incorrect keys
Summary: libmodulemd emits modulemd-defaults with incorrect keys
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libmodulemd
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-04-16 12:37 UTC by Petr Šabata
Modified: 2018-04-18 01:24 UTC (History)
4 users (show)

Fixed In Version: libmodulemd-1.3.0-2.fc28 libmodulemd-1.3.0-2.el7 libmodulemd-1.3.0-2.fc26 libmodulemd-1.3.0-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 00:21:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Šabata 2018-04-16 12:37:44 UTC
Dumping modulemd-defaults documents produces invalid data, using 'name' where 'module' should be instead.  This results in broken defaults in the repodata in F28:

# dnf update   
Last metadata expiration check: 0:21:03 ago on Mon 16 Apr 2018 02:15:28 PM CEST.
** Message: 14:36:31.667: Module name not specified
** Message: 14:36:31.667: Invalid [ModulemdDefaults] document [Module name not specified].
** Message: 14:36:31.667: Invalid document [Module name not specified]. Skipping it.
** Message: 14:36:31.667: Module name not specified
** Message: 14:36:31.668: Invalid [ModulemdDefaults] document [Module name not specified].
** Message: 14:36:31.668: Invalid document [Module name not specified]. Skipping it.
** Message: 14:36:31.668: Module name not specified
** Message: 14:36:31.668: Invalid [ModulemdDefaults] document [Module name not specified].
** Message: 14:36:31.668: Invalid document [Module name not specified]. Skipping it.
Dependencies resolved.
(...)

Reproducible with both 1.2.0 and 1.3.0.

The fixed version will need to be deployed on Fedora composers to truly resolve this issue.

Comment 1 Fedora Blocker Bugs Application 2018-04-16 12:43:01 UTC
Proposed as a Blocker for 28-final by Fedora user sgallagh using the blocker tracking app because:

 This *loosely* violates
"The installed system must be able to download and install updates with the default console package manager."

What happens is that libmodulemd (in use by DNF) will ignore the offending defaults metadata and as a result, packages that should appear as available by default to DNF will instead be treated as only available as optional modules.

Given that default enablement is a critical feature of Modularity (previously agreed by FESCo to be blocking for F28), I am proposing this for the same.

Note that the bug has already been located and fixed upstream in libmodulemd and that an update is forthcoming.

Comment 2 Fedora Update System 2018-04-16 12:54:30 UTC
libmodulemd-1.3.0-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-59d7f7af7d

Comment 3 Fedora Update System 2018-04-16 12:54:39 UTC
libmodulemd-1.3.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-764f270b0e

Comment 4 Fedora Update System 2018-04-16 12:54:44 UTC
libmodulemd-1.3.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0f04084368

Comment 5 Fedora Update System 2018-04-16 12:54:49 UTC
libmodulemd-1.3.0-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-727698a797

Comment 6 František Zatloukal 2018-04-16 17:00:12 UTC
Discussed during the 2018-04-16 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"accepted as a clear violation of the requirements for Modularity specified in https://bugzilla.redhat.com/show_bug.cgi?id=1537253#c6 , as FESCo has declared modularity blocking F28"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-04-16/f28-blocker-review.2018-04-16-16.00.log.txt

Comment 7 Fedora Update System 2018-04-17 00:21:48 UTC
libmodulemd-1.3.0-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Stephen Gallagher 2018-04-17 11:43:53 UTC
*** Bug 1568277 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2018-04-18 00:37:32 UTC
libmodulemd-1.3.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-04-18 01:04:25 UTC
libmodulemd-1.3.0-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-04-18 01:24:11 UTC
libmodulemd-1.3.0-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.