Bug 1568277 - Don't display unexpected [Module name not specified] warnings
Summary: Don't display unexpected [Module name not specified] warnings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libmodulemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 06:31 UTC by Vít Ondruch
Modified: 2018-05-12 20:23 UTC (History)
6 users (show)

Fixed In Version: libmodulemd-1.4.0-2.fc28 libmodulemd-1.4.0-2.fc26 libmodulemd-1.4.0-2.fc27 libmodulemd-1.4.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 23:08:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Vít Ondruch 2018-04-17 06:31:21 UTC
Description of problem:

~~~
$ sudo dnf update dnf
Failed to synchronize cache for repo 'rcm-tools-fedora-rpms', disabling.
Last metadata expiration check: 1:33:28 ago on Tue Apr 17 06:55:25 2018.
** Message: 08:28:54.695: Module name not specified
** Message: 08:28:54.695: Invalid [ModulemdDefaults] document [Module name not specified].
** Message: 08:28:54.695: Invalid document [Module name not specified]. Skipping it.
** Message: 08:28:54.695: Module name not specified
** Message: 08:28:54.695: Invalid [ModulemdDefaults] document [Module name not specified].
** Message: 08:28:54.695: Invalid document [Module name not specified]. Skipping it.
** Message: 08:28:54.695: Module name not specified
** Message: 08:28:54.695: Invalid [ModulemdDefaults] document [Module name not specified].
** Message: 08:28:54.695: Invalid document [Module name not specified]. Skipping it.
Dependencies resolved.
Nothing to do.
Complete!
~~~

I have no idea what the messages above means and I would appreciate if they can be either clarified or better removed.


Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-2.7.5-10.fc29.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Some unexpected "module" messages are shown.


Expected results:
No "module" messages are shown.


Additional info:

Comment 1 Martin Hatina 2018-04-17 07:02:03 UTC
Warnings come from libmodulemd, Reassigning.

Comment 2 Stephen Gallagher 2018-04-17 11:43:53 UTC
This error message is actually correct. The bug here was that the repodata was being generated with the wrong key for module name.

*** This bug has been marked as a duplicate of bug 1567921 ***

Comment 3 Vít Ondruch 2018-04-17 12:00:33 UTC
(In reply to Stephen Gallagher from comment #2)
You say that "the repodata was being generated with the wrong key for module name.", but I can't see any link between the messages and what you said. Why the message says something completely incomprehensible?

Comment 4 Stephen Gallagher 2018-04-17 13:24:27 UTC
The repodata YAML was generated with the word “name” instead of the word “module” to reference the module this defaults object applies to. libmodulemd is a strict parser, and because it can’t figure out what module this document is meant to apply to, it skips it and warns that the reason it was skipped was that it had no module name.

I suppose I could try to figure out a different phrasing, but “Invalid [ModulemdDefaults] document. [Module name not specified]” reads fairly clearly to me.

Comment 5 Vít Ondruch 2018-04-18 09:45:55 UTC
(In reply to Stephen Gallagher from comment #4)
> I suppose I could try to figure out a different phrasing, but “Invalid
> [ModulemdDefaults] document. [Module name not specified]” reads fairly
> clearly to me.

No, it does not. I read it as I should specify some modulename somewhere on DNF command line, which is apparently not the case. It does not mention repository data or anything else.

Really, this message might make a sense in libmodulemd context, but does not make any sense in DNF context.

TBH, it is surprising to see some libmodulemd message in DNF output.

Comment 6 Stephen Gallagher 2018-04-18 11:14:42 UTC
(In reply to Vít Ondruch from comment #5)
> (In reply to Stephen Gallagher from comment #4)
> > I suppose I could try to figure out a different phrasing, but “Invalid
> > [ModulemdDefaults] document. [Module name not specified]” reads fairly
> > clearly to me.
> 
> No, it does not. I read it as I should specify some modulename somewhere on
> DNF command line, which is apparently not the case. It does not mention
> repository data or anything else.
> 
> Really, this message might make a sense in libmodulemd context, but does not
> make any sense in DNF context.
> 
> TBH, it is surprising to see some libmodulemd message in DNF output.

Yeah, you're correct about that... I'll see what I can do about it. I'm a little wary of turning it off by default though; because of a mistake (mine) in the API design, right now it's the only way for us to know if a defaults document is being skipped because it was incorrect.

I'll reopen this ticket and use it to track fixing that for 2.0.0 (because it will probably involve an ABI break).

Comment 7 Vít Ondruch 2018-04-18 12:26:47 UTC
Wonderful, thx. Looking forward to it.

Comment 8 Fedora Update System 2018-04-25 18:19:54 UTC
libmodulemd-1.4.0-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3967567d37

Comment 9 Fedora Update System 2018-04-25 18:20:05 UTC
libmodulemd-1.4.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b882e25943

Comment 10 Fedora Update System 2018-04-25 18:20:12 UTC
libmodulemd-1.4.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-de1730ac2f

Comment 11 Fedora Update System 2018-04-25 18:20:20 UTC
libmodulemd-1.4.0-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e46780b82c

Comment 12 Stephen Gallagher 2018-04-25 18:22:08 UTC
I was able to avoid an ABI break, so this made it into 1.4.0. Now all of the libmodulemd messages are triggered at DEBUG level only, and only if `G_DEBUG_MESSAGES=libmodulemd` (or "all") is set in the environment.

Comment 13 Fedora Update System 2018-04-26 04:53:39 UTC
libmodulemd-1.4.0-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-de1730ac2f

Comment 14 Vít Ondruch 2018-04-26 06:53:24 UTC
(In reply to Stephen Gallagher from comment #12)
Thx. I have not tested it, but it sounds promising :)

Comment 15 Fedora Update System 2018-04-27 05:09:05 UTC
libmodulemd-1.4.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b882e25943

Comment 16 Fedora Update System 2018-04-27 07:13:45 UTC
libmodulemd-1.4.0-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e46780b82c

Comment 17 Fedora Update System 2018-04-27 07:54:48 UTC
libmodulemd-1.4.0-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3967567d37

Comment 18 Fedora Update System 2018-04-27 23:08:02 UTC
libmodulemd-1.4.0-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2018-05-05 21:24:25 UTC
libmodulemd-1.4.0-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-05-05 22:26:39 UTC
libmodulemd-1.4.0-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2018-05-12 20:23:00 UTC
libmodulemd-1.4.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.