Bug 1568367 - Use environment files for setting/unsetting heat resources during major upgrade, minor update and ffwd-upgrade
Summary: Use environment files for setting/unsetting heat resources during major upgra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: All
OS: All
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Marios Andreou
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1568548 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 11:15 UTC by Marios Andreou
Modified: 2018-06-27 13:51 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180416194360.29a5ad5.el7ost python-tripleoclient-9.2.0-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:51:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 561178 None stable/queens: MERGED tripleo-heat-templates: Add prepare/converge env files for update (I486ad0d44f105a6fa9fd24dcf7ac28d40ceecc27) 2018-04-19 14:29:35 UTC
OpenStack gerrit 561207 None stable/queens: MERGED python-tripleoclient: Add upgrade-[prepare|converge].yaml into upgrade cli (I1288fe68ae8af02a5d77390d237ec467d88e43d2) 2018-04-19 14:29:30 UTC
OpenStack gerrit 561208 None stable/queens: MERGED tripleo-heat-templates: Update environment files for Q upgrade and ffwd upgrade (Icfe494e3219d6d6cd3251f75bb4329fc4d793c... 2018-04-19 14:29:25 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:45 UTC

Description Marios Andreou 2018-04-17 11:15:20 UTC
Description of problem:
For OSP13 all the upgrades related clis ("openstack overcloud upgrade", "openstack overcloud update", "openstack overcloud ffwd-upgrade") have a 'prepare' subcommand where we generate ansible playbooks with a heat stack update. During this stack update we 'noop' the deployment config since we don't want config applied during this step. This is achieved with [1] to set and [2] to unset. 

Doing this is not scalable as we now have to add more resources for no-op specific to the ffwd-upgrade cli. Furthermore we would also have to deal with unset of resources used during the major upgrade, such as the UpgradeInitCommand.

Instead we should use environment files specific to each operation and which will be inserted into the heat call by the tripleoclient.

[1] https://github.com/openstack/tripleo-common/blob/6090d32b516f92837fc8b01b7a55dc97ed3e8a77/tripleo_common/actions/package_update.py#L62-L76
[2] https://github.com/openstack/tripleo-common/blob/6090d32b516f92837fc8b01b7a55dc97ed3e8a77/tripleo_common/actions/plan.py#L492-L502

Comment 2 Marios Andreou 2018-04-18 06:49:51 UTC
*** Bug 1568548 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2018-06-27 13:51:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.