Bug 1568380 - sos should be installed in amphora image
Summary: sos should be installed in amphora image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-octavia
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Carlos Goncalves
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On: 1541100
Blocks: 1433523
TreeView+ depends on / blocked
 
Reported: 2018-04-17 11:44 UTC by Carlos Goncalves
Modified: 2019-09-10 14:10 UTC (History)
7 users (show)

Fixed In Version: openstack-octavia-2.0.1-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:51:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 561860 None master: MERGED octavia: Add sos element to Red Hat family images (I5131a4cfdedd8b78fb673b4264ef1d7a1d613972) 2018-05-02 15:23:44 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:51:45 UTC

Description Carlos Goncalves 2018-04-17 11:44:58 UTC
Description of problem:
sosreport is not installed in the amphora image. Without it customers cannot generate and share reports.

How reproducible:
100%

Steps to Reproduce:
1. $ sosreport
-bash: sosreport: command not found

Actual results:
"sosreport" CLI (/usr/sbin/sosreport) not present

Expected results:
Package "sos" should be installed.

$ rpm -q sos
sos-3.5-6.el7.noarch
$ which sosreport
/usr/sbin/sosreport

Workaround:
$ yum install sos


Additional info:

We'll tentatively try to have it addressed upstream during image build for Red Hat family images. Alternatively, we'll need to "virt-customize --install sos" downstream.

Comment 11 errata-xmlrpc 2018-06-27 13:51:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.