Bug 1568436 - glusterd is releasing the locks before timeout
Summary: glusterd is releasing the locks before timeout
Keywords:
Status: CLOSED DUPLICATE of bug 1577731
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 13:47 UTC by Sanju
Modified: 2018-05-17 03:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 03:28:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sanju 2018-04-17 13:47:39 UTC
Description of problem:
nfs enable is sometimes returning failure

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
root@dhcp42-39 ~]# time gluster --mode=script nfs-ganesha enable
This will take a few minutes to complete. Please wait ..
nfs-ganesha: failed

real    3m10.324s
user    0m0.220s
sys    0m0.259s
[root@dhcp42-39 ~]# time gluster --mode=script nfs-ganesha disable
This will take a few minutes to complete. Please wait ..
nfs-ganesha : success

real    2m23.626s
user    0m0.207s
sys    0m0.265s
[root@dhcp42-39 ~]# time gluster --mode=script nfs-ganesha enable
This will take a few minutes to complete. Please wait ..
nfs-ganesha: failed

real    3m9.396s
user    0m0.197s
sys    0m0.272s



Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-04-17 13:49:51 UTC
REVIEW: https://review.gluster.org/19890 (glusterd/nfs: Fix for nfs enable timeout) posted (#1) for review on master by Sanju Rakonde

Comment 2 Sanju 2018-04-17 15:37:00 UTC
We introduced unlock timer in mgmt v3, which will realease the lock after 3 minutes of command execution. Some commands related to heal/profile will take more time to execute. For these comands timeout is set to 10 minutes. As the unblock timer is set to 3 minutes glusterd is releasing the lock after 3 minutes. That means locks are released before the command is completed its execution.

Comment 3 Sanju 2018-05-17 03:28:17 UTC

*** This bug has been marked as a duplicate of bug 1577731 ***

Comment 4 Worker Ant 2018-05-17 03:39:27 UTC
REVISION POSTED: https://review.gluster.org/19890 (glusterd: glusterd is releasing the locks before timeout) posted (#6) for review on master by Sanju Rakonde


Note You need to log in before you can comment on or make changes to this bug.