Bug 1577731 - [Ganesha] "Gluster nfs-ganesha enable" commands sometimes gives output as "failed" with "Unlocking failed" error messages ,even though cluster is up and healthy in backend
Summary: [Ganesha] "Gluster nfs-ganesha enable" commands sometimes gives output as "fa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
: 1568436 (view as bug list)
Depends On: 1575557
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-14 04:20 UTC by Sanju
Modified: 2018-10-23 15:08 UTC (History)
11 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1575557
Environment:
Last Closed: 2018-10-23 15:08:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-05-14 17:04:06 UTC
REVIEW: https://review.gluster.org/20021 (glusterd: glusterd is releasing the locks before timeout) posted (#1) for review on master by Sanju Rakonde

Comment 2 Sanju 2018-05-17 03:28:17 UTC
*** Bug 1568436 has been marked as a duplicate of this bug. ***

Comment 3 Worker Ant 2018-05-17 03:39:29 UTC
REVIEW: https://review.gluster.org/19890 (glusterd: glusterd is releasing the locks before timeout) posted (#6) for review on master by Sanju Rakonde

Comment 4 Worker Ant 2018-05-28 14:11:12 UTC
COMMIT: https://review.gluster.org/19890 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- glusterd: glusterd is releasing the locks before timeout

Problem: We introduced lock timer in mgmt v3, which will realease
the lock after 3 minutes from command execution. Some commands related
to heal/profile will take more time to execute. For these comands
timeout is set to 10 minutes. As the lock timer is set to 3 minutes
glusterd is releasing the lock after 3 minutes. That means locks are
released before the command is completed its execution.

Solution: Pass a timeout parameter from cli to glusterd, when there
is a change in default timeout value(i.e, default timeout value can
be changed through command line or for the commands related to profile/heal
we will change the default timeout value to 10 minutes.) glusterd will
set the lock timer timeout according to the timeout value passed.

Change-Id: I7b7a9a4f95ed44aca39ef9d9907f546bca99c69d
fixes: bz#1577731
Signed-off-by: Sanju Rakonde <srakonde@redhat.com>

Comment 5 Shyamsundar 2018-10-23 15:08:41 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.