Bug 1568675 - Endless loop if checksetup can't contact DB
Summary: Endless loop if checksetup can't contact DB
Keywords:
Status: CLOSED DUPLICATE of bug 1575809
Alias: None
Product: Bugzilla
Classification: Community
Component: Database
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 05:24 UTC by Jeff Fearn 🐞
Modified: 2018-05-09 23:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 23:41:08 UTC


Attachments (Terms of Use)

Description Jeff Fearn 🐞 2018-04-18 05:24:51 UTC
Description of problem:
If you run check setup and it can;t login to the DB it can get in to an endless loop trying to send mail.

Version-Release number of selected component (if applicable):
5.0

How reproducible:
Tricky?

Steps to Reproduce:
1. run check setup when the db connection gets auto rejected


Actual results:
Deep recursion on subroutine "Bugzilla::dbh" at Bugzilla/Object.pm line 107.
Deep recursion on subroutine "Bugzilla::dbh_main" at Bugzilla.pm line 563.
Deep recursion on subroutine "Bugzilla::DB::connect_main" at Bugzilla.pm line 567.
Deep recursion on subroutine "Bugzilla::DB::_connect" at Bugzilla/DB.pm line 124.
Deep recursion on subroutine "Bugzilla::DB::Pg::new" at Bugzilla/DB.pm line 139.
Deep recursion on subroutine "Bugzilla::DB::db_new" at Bugzilla/DB/Pg.pm line 59.
Deep recursion on subroutine "Bugzilla::Mailer::MessageToMTA" at Bugzilla/DB.pm line 1402.
Deep recursion on subroutine "Bugzilla::User::new" at Bugzilla/Mailer.pm line 138.
Deep recursion on subroutine "Bugzilla::Object::new" at Bugzilla/User.pm line 135.
Deep recursion on subroutine "Bugzilla::Object::_load_from_db" at Bugzilla/Object.pm line 83.

Expected results:


Additional info:
# psql -U db_user --port 9999 -h $db_server $db_name
psql: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.

Comment 1 Jeff Fearn 🐞 2018-05-09 23:41:08 UTC

*** This bug has been marked as a duplicate of bug 1575809 ***


Note You need to log in before you can comment on or make changes to this bug.