Bug 1568783 - TemplateRuntimeError: no test named 'equalto'
Summary: TemplateRuntimeError: no test named 'equalto'
Keywords:
Status: CLOSED DUPLICATE of bug 1564180
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 09:05 UTC by Aleks Lazic
Modified: 2018-04-18 16:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 16:08:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Aleks Lazic 2018-04-18 09:05:43 UTC
Description of problem:

We faced the following problem at the update from OCP 3.7.23-1 to 3.7.42-1

Version-Release number of the following components:

cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.4 (Maipo)

rpm -q openshift-ansible
openshift-ansible-3.7.42-1.git.0.427f18c.el7.noarch

rpm -q ansible
ansible-2.4.2.0-2.el7.noarch

ansible --version
ansible 2.4.2.0
  config file = /var/tmp/ocp06/ose/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /bin/ansible
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]

How reproducible:

Steps to Reproduce:
1. Install OCP 3.7.23-1 on RHEL 7.4
2. Update RHEL 7.4 to latest
3. Install atomic-openshift-docker-excluder and atomic-openshift-excluder from 3.7.42-1
4. call ansible-playbook -i ./hosts /usr/share/ansible/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_7/upgrade_control_plane.yml | tee upgrade_control_plane.log.$(date '+%d%m%Y_%H%M')

Actual results:
TASK [Upgrade master packages] **************************************************************************************************************************************************************************************************************
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: TemplateRuntimeError: no test named 'equalto'
fatal: [ocpm01]: FAILED! => {"msg": "Unexpected failure during module execution.", "stdout": ""}


Expected results:

The update should be done without errors

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Aleks Lazic 2018-04-18 09:33:21 UTC
Looks like that this is the similar issue as on github https://github.com/openshift/openshift-ansible/issues/3463

Comment 2 Aleks Lazic 2018-04-18 09:44:49 UTC
rpm -q python-jinja2
python-jinja2-2.7.2-2.el7.noarch

yum install python-jinja2
...
Package python-jinja2-2.7.2-2.el7.noarch already installed and latest version
Nothing to do
...

Comment 3 liujia 2018-04-18 10:40:23 UTC
Refer to https://bugzilla.redhat.com/show_bug.cgi?id=1564182

Fixed on openshift-ansible-3.7.42-1.git.2.9ee4e71.el7.noarch

Comment 4 Scott Dodson 2018-04-18 16:08:58 UTC

*** This bug has been marked as a duplicate of bug 1564180 ***


Note You need to log in before you can comment on or make changes to this bug.