Bug 1568870 - VDO feature should be enabled based on the availability of compatible gdeploy rpm
Summary: VDO feature should be enabled based on the availability of compatible gdeploy...
Keywords:
Status: CLOSED DUPLICATE of bug 1568725
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.12
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 10:55 UTC by SATHEESARAN
Modified: 2018-04-18 11:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 11:29:07 UTC
oVirt Team: Gluster
sasundar: ovirt-4.2?
sasundar: blocker?
sasundar: planning_ack?
sasundar: devel_ack?
sasundar: testing_ack?


Attachments (Terms of Use)

Description SATHEESARAN 2018-04-18 10:55:22 UTC
Description of problem:
-----------------------
gdeploy supports VDO feature, only after the gdeploy builds > 2.0.2-19
So in case, if RHVH contains gdeploy < = 2.0.2-19, then VDO features should not be exposed in cockpit UI

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
cockpit-ovirt-dashboard-0.11.21

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Install gdeploy-2.0.2-19 ( which doesn't have support for VDO )
2. Use cockpit UI, to setup gluster configurations
3. Check for VDO feature exposure

Actual results:
---------------
VDO feature is exposed in cockpit UI even when gdeploy doesn't supports VDO

Expected results:
------------------
VDO feature should be exposed in the cockpit UI, only when gdeploy supports VDO

Comment 1 Sahina Bose 2018-04-18 11:29:07 UTC

*** This bug has been marked as a duplicate of bug 1568725 ***


Note You need to log in before you can comment on or make changes to this bug.