Bug 1569192 - [RFE] osd: Warn about objects with too many omap entries
Summary: [RFE] osd: Warn about objects with too many omap entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 3.1
Assignee: Brad Hubbard
QA Contact: Parikshith
John Brier
URL:
Whiteboard:
: 1457767 (view as bug list)
Depends On:
Blocks: 1430588 1584264
TreeView+ depends on / blocked
 
Reported: 2018-04-18 18:48 UTC by Vikhyat Umrao
Modified: 2020-12-14 11:03 UTC (History)
12 users (show)

Fixed In Version: RHEL: ceph-12.2.5-13.el7cp Ubuntu: 12.2.5-4redhat1xenial
Doc Type: Enhancement
Doc Text:
.Warnings about objects with too many omap entries With this update to {product} warnings are displayed about pools which contain large omap objects. They can be seen in the output of `ceph health detail`. Information about the large objects in the pool are printed in the cluster logs. The settings which control when the warnings are printed are `osd_deep_scrub_large_omap_object_key_threshold` and `osd_deep_scrub_large_omap_object_value_sum_threshold`.
Clone Of:
Environment:
Last Closed: 2018-09-26 18:19:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 23784 0 None None None 2018-04-18 18:49:35 UTC
Red Hat Product Errata RHBA-2018:2819 0 None None None 2018-09-26 18:20:44 UTC

Description Vikhyat Umrao 2018-04-18 18:48:37 UTC
Description of problem:
[RFE] osd: Warn about objects with too many omap entries

As discussed in upstream PR - https://github.com/ceph/ceph/pull/16332 assigning it to Brad.


Version-Release number of selected component (if applicable):
RHCS 3.0

How reproducible:

Comment 1 Vikhyat Umrao 2018-05-01 19:38:32 UTC
Upstream backport - https://github.com/ceph/ceph/pull/21518

Comment 7 Josh Durgin 2018-06-26 05:33:50 UTC
*** Bug 1457767 has been marked as a duplicate of this bug. ***

Comment 10 Brad Hubbard 2018-09-06 23:14:24 UTC
This looks fine guys, thanks.

Comment 12 errata-xmlrpc 2018-09-26 18:19:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.