Bug 1569486 - need example for creating arbiter volume when we do "heketi-cli volume create --help"
Summary: need example for creating arbiter volume when we do "heketi-cli volume create...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.10
Assignee: John Mulligan
QA Contact: Nitin Goyal
URL:
Whiteboard:
Depends On:
Blocks: 1568862
TreeView+ depends on / blocked
 
Reported: 2018-04-19 11:38 UTC by Nitin Goyal
Modified: 2018-09-12 09:23 UTC (History)
8 users (show)

Fixed In Version: heketi-6.0.0-14.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
"heket-cli volume create --help" output (1.33 KB, text/plain)
2018-04-19 11:38 UTC, Nitin Goyal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:14 UTC

Description Nitin Goyal 2018-04-19 11:38:43 UTC
Created attachment 1424018 [details]
"heket-cli volume create --help" output

Description of problem: --help is not showing arbiter volume create example. It should be there for easyness.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. heketi-cli volume create --help

Actual results: It is not showing the example regarding arbiter volume create.


Expected results: It should show the example regarding arbiter volume create.

Comment 2 John Mulligan 2018-04-25 14:51:30 UTC
Because arbiter is triggered via the volume options list and the volume options list on the CLI is somewhat free form, I feel that this is a bit out of scope for the built-in cli help.
However, we could add an example to the heketi-cli manpage.

Comment 7 Nitin Goyal 2018-06-08 12:28:37 UTC
As we can see that there is still no option for arbiter in "heketi-cli volume create --help" so marking it as failed 

[root@dhcp46-81 home]# heketi-cli volume create --help
Create a GlusterFS volume

Usage:
  heketi-cli volume create [flags]

Examples:
  * Create a 100GiB replica 3 volume:
      $ heketi-cli volume create --size=100

  * Create a 100GiB replica 3 volume specifying two specific clusters:
      $ heketi-cli volume create --size=100 \
        --clusters=0995098e1284ddccb46c7752d142c832,60d46d518074b13a04ce1022c8c7193c

  * Create a 100GiB replica 2 volume with 50GiB of snapshot storage:
      $ heketi-cli volume create --size=100 --snapshot-factor=1.5 --replica=2

  * Create a 100GiB distributed volume
      $ heketi-cli volume create --size=100 --durability=none

  * Create a 100GiB erasure coded 4+2 volume with 25GiB snapshot storage:
      $ heketi-cli volume create --size=100 --durability=disperse --snapshot-factor=1.25

  * Create a 100GiB erasure coded 8+3 volume with 25GiB snapshot storage:
      $ heketi-cli volume create --size=100 --durability=disperse --snapshot-factor=1.25 \
        --disperse-data=8 --redundancy=3

  * Create a 100GiB distributed volume which supports performance related volume options.
      $ heketi-cli volume create --size=100 --durability=none --gluster-volume-options="performance.rda-cache-limit 10MB","performance.nl-cache-positive-entry no"

Comment 8 Raghavendra Talur 2018-06-08 12:31:06 UTC
Nitin,

Provide client version number please. If this is latest build then there might be something wrong with build.

Comment 9 Nitin Goyal 2018-06-08 12:41:13 UTC
Raghavendra,

It is there in man page as mentioned in comment 2, I did not saw that comment it is verified.
I think we should add one example for avg size arbiter as well.

EXAMPLES
   List Volumes
       Specify the Heketi server to contact using an environment variable and list the volumes.
              $ export HEKETI_CLI_SERVER=http://localhost:8080
              $ heketi-cli volume list

   Create a Volume
       Create a 4 GiB volume.
              $ heketi-cli volume create --size 4

   Create an Arbiter Volume
       Create a 4 GiB volume that uses the arbiter feature.
              $ heketi-cli volume create --size 4 --gluster-volume-options='user.heketi.arbiter true'

Comment 11 errata-xmlrpc 2018-09-12 09:22:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.