Bug 1569909 - UnicodeWarning while trying to attach subscription
Summary: UnicodeWarning while trying to attach subscription
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.10
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
: 1635580 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 08:54 UTC by Shwetha Kallesh
Modified: 2019-07-10 12:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-10 12:01:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1639086 0 unspecified CLOSED subscription manager sends package report to the Satellite even nothing has changed . 2021-02-22 00:41:40 UTC

Internal Links: 1639086

Description Shwetha Kallesh 2018-04-20 08:54:39 UTC
Description of problem:
UnicodeWarning while trying to attach subscription,this is after-effects of the 
copying customer provided packages mentioned in the bug 
https://bugzilla.redhat.com/show_bug.cgi?id=1544768#c0

Version-Release number of selected component (if applicable):
[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.2.3-1
subscription management rules: 5.26
subscription-manager: 1.20.10-6.el6


How reproducible:


Steps to Reproduce:
[root@localhost ~]# subscription-manager attach --pool 8a99f98961f90e410162007a33e05e36
/usr/lib64/python2.6/site-packages/rhsm/profile.py:68: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  self.vendor == other.vendor:
Successfully attached a subscription for: Red Hat OpenStack Platform, Premium (2-sockets) L3-Only


Actual results:


Expected results:


Additional info:

Comment 2 Kevin Howell 2018-04-23 14:28:29 UTC
Assumption is that the effect is that for a customer with packages such as this, the package profile is sent when it hasn't changed.

Comment 3 Kevin Howell 2018-08-01 15:47:06 UTC
Is this an issue on RHEL7 as well?

Comment 4 Shwetha Kallesh 2018-08-06 11:44:17 UTC
Issue is reproducable on rhel7.6 as well

[root@kvm-guest-04 rpm]# subscription-manager  version
server type: Red Hat Subscription Management
subscription management server: 2.2.3-1
subscription management rules: 5.26
subscription-manager: 1.21.5-7.el7

[root@kvm-guest-04 rpm]# scp skallesh@10.3.112.16:/home/skallesh/Downloads/Packages Packages.cu
skallesh@10.3.112.16's password: 
Packages                                                                                                                                                                                                    100%   54MB 566.9KB/s   01:38    
[root@kvm-guest-04 rpm]# /usr/lib/rpm/rpmdb_verify Packages.cu
BDB5105 Verification of Packages.cu succeeded.

[root@kvm-guest-04 rpm]# rpm -v --rebuilddb

[root@kvm-guest-04 rpm]# subscription-manager  attach --pool 8a99f9865ea4b788015ea511530003a8
/usr/lib64/python2.7/site-packages/rhsm/profile.py:68: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  self.vendor == other.vendor:
Successfully attached a subscription for: Red Hat Enterprise Linux, Premium (up to 2 sockets)

Comment 5 Prajeesh 2018-11-04 00:43:44 UTC
Hi,

We have reproduced the issue on RHEL 7 servers also.

1. Get the file  "/var/lib/rpm/Packages" from the customer and restored in my 

test system.

2. Ran the command "katello-package-upload" it throwing mentioned waring 

message.

Additional Info:

"katello-package-upload --force" work without any warning message.

Error:

/usr/lib64/python2.7/site-packages/rhsm/profile.py:68: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  self.vendor == other.vendor:

Regards,
Prajeesh

Comment 6 Kevin Howell 2019-01-09 16:43:16 UTC
*** Bug 1635580 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.