Bug 1635580 - UnicodeWarning while trying to run katello-package-upload
Summary: UnicodeWarning while trying to run katello-package-upload
Keywords:
Status: CLOSED DUPLICATE of bug 1569909
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: katello-agent
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1635579 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-03 10:10 UTC by Prajeesh
Modified: 2019-08-12 19:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-09 16:43:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Prajeesh 2018-10-03 10:10:50 UTC
Description of problem:

UnicodeWarning while trying to run katello-package-upload.

Error:

/usr/lib64/python2.7/site-packages/rhsm/profile.py:68: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
  self.vendor == other.vendor:


How reproducible:

1. Get the file  "/var/lib/rpm/Packages" from the customer and restored in my 

test system.

2. Ran the command "katello-package-upload" it throwing mentioned waring 

message.

Additional Info:

"katello-package-upload --force" work without any warning message.

Comment 1 Brad Buckingham 2018-10-05 15:37:34 UTC
*** Bug 1635579 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Howell 2019-01-09 16:43:16 UTC
This behavior comes from the subscription-manager or python-rhsm package, and thus is a dupe of either bug 1569909 (or bug 1639086 on RHEL7).

*** This bug has been marked as a duplicate of bug 1569909 ***


Note You need to log in before you can comment on or make changes to this bug.