Bug 1570057 - RHEL7 MapR 5.2 images from sahara-image-pack requires an active RHSM subscription
Summary: RHEL7 MapR 5.2 images from sahara-image-pack requires an active RHSM subscrip...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks: 1502853
TreeView+ depends on / blocked
 
Reported: 2018-04-20 14:26 UTC by Luigi Toscano
Modified: 2018-06-27 13:53 UTC (History)
5 users (show)

Fixed In Version: openstack-sahara-8.0.1-0.20180328233737.36531cb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:52:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack Storyboard 2001773 None None None 2018-04-20 14:26:10 UTC
OpenStack gerrit 562722 None MERGED Fix MapR dependency on mysql on RHEL 2020-09-14 20:49:48 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:53:11 UTC

Description Luigi Toscano 2018-04-20 14:26:11 UTC
Description of problem:
The MapR images produces by sahara-image-elements do not need it. If a RHEL7 images without subscription is used, the following error is throwin during the creation of a cluster (can be seen with scenario tests):

Captured traceback:
~~~~~~~~~~~~~~~~~~~
    Traceback (most recent call last):
      File "/tmp/tmpNQN3cm/test_iZLEF9.py", line 16, in test_plugin
        self.create_cluster()
      File "/usr/lib/python2.7/site-packages/sahara_tests/scenario/base.py", line 158, in create_cluster
        self._poll_cluster_status_tracked(self.cluster_id)
      File "/usr/lib/python2.7/site-packages/sahara_tests/scenario/base.py", line 62, in wrapper
        return fct(self, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/sahara_tests/scenario/base.py", line 641, in _poll_cluster_status_tracked
        self._poll_cluster_status(cluster_id)
      File "/usr/lib/python2.7/site-packages/sahara_tests/scenario/base.py", line 658, in _poll_cluster_status
        raise exc.TempestException(message)
    tempest.lib.exceptions.TempestException: An unknown exception occurred
    Details: Cluster in Error state with a message below:
    Creating cluster failed for the following reason(s): An error occurred in thread 'wrapped-execution': RemoteCommandException: Error during command execution: "yum install -y mapr-zookeeper mapr-webserver mapr-
metrics"
    Return code: 1
    STDERR:
    Error: Package: mapr-metrics-5.2.0.39122.GA-1.x86_64 (mapr_core)
               Requires: mysql-connector-java >= 5.1.0

    STDOUT:
    Loaded plugins: search-disabled-repos
    Resolving Dependencies
    --> Running transaction check
    ---> Package mapr-metrics.x86_64 0:5.2.0.39122.GA-1 will be installed
    --> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics-5.2.0.39122.GA-1.x86_64
    --> Processing Dependency: soci-mysql for package: mapr-metrics-5.2.0.39122.GA-1.x86_64
    ---> Package mapr-webserver.x86_64 0:5.2.0.39122.GA-1 will be installed
    ---> Package mapr-zookeeper.x86_64 0:5.2.0.39122.GA-1 will be installed
    --> Processing Dependency: mapr-zk-internal for package: mapr-zookeeper-5.2.0.39122.GA-1.x86_64
    --> Running transaction check
    ---> Package mapr-metrics.x86_64 0:5.2.0.39122.GA-1 will be installed
    --> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics-5.2.0.39122.GA-1.x86_64
    ---> Package mapr-zk-internal.x86_64 0:5.2.0.39122.GA-1 will be installed
    ---> Package soci-mysql.x86_64 0:3.2.3-1.el7 will be installed
    --> Processing Dependency: soci(x86-64) = 3.2.3-1.el7 for package: soci-mysql-3.2.3-1.el7.x86_64
    --> Processing Dependency: libsoci_core.so.3.2()(64bit) for package: soci-mysql-3.2.3-1.el7.x86_64
    --> Running transaction check
    ---> Package mapr-metrics.x86_64 0:5.2.0.39122.GA-1 will be installed
    --> Processing Dependency: mysql-connector-java >= 5.1.0 for package: mapr-metrics-5.2.0.39122.GA-1.x86_64
    ---> Package soci.x86_64 0:3.2.3-1.el7 will be installed
    --> Finished Dependency Resolution
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest


This is a regression compared to the behavior of an image produced by sahara-image-elements, where the necessary packages are already available in the image and there should be no need to add additional packages from the base channels of CentOS7/RHEL7. This is not generally a problem on CentOS7, apart from the slow down (the packages are installed during the runtime phase) but this means that a RHEL7 image should have an active subscription. This may be desiderable or not; nevertheless, still a change of behavior compared to sahara-image-elements.

Version-Release number of selected component (if applicable):
openstack-sahara-image-pack-8.0.1-0.20180320232516.d3322ef.el7ost

Steps to Reproduce:
sahara-image-pack --image sahara-rhel7-mapr-520.qcow2 mapr 5.2.0

Comment 5 Luigi Toscano 2018-04-30 15:27:59 UTC
The packages mariadb, mariadb-libs, mariadb-server, mysql-connector-java are installed correctly in the image, and no other packages are required during the cluster creation time.

Verified on:
openstack-sahara-image-pack-8.0.1-0.20180328233737.36531cb.el7ost
python-sahara-8.0.1-0.20180328233737.36531cb.el7ost.noarch
libguestfs-1.36.10-6.el7.x86_64

Comment 7 errata-xmlrpc 2018-06-27 13:52:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.