Bug 1570063 - sahara-image-pack: scala and ntp/ntpdate are not installed on MapR 5.2 images
Summary: sahara-image-pack: scala and ntp/ntpdate are not installed on MapR 5.2 images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks: 1502853
TreeView+ depends on / blocked
 
Reported: 2018-04-20 14:43 UTC by Luigi Toscano
Modified: 2018-06-27 13:53 UTC (History)
5 users (show)

Fixed In Version: openstack-sahara-8.0.1-0.20180328233737.36531cb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:52:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack Storyboard 2001833 None None None 2018-04-20 15:01:18 UTC
OpenStack Storyboard 2001834 None None None 2018-04-20 15:28:43 UTC
OpenStack gerrit 563109 None None None 2018-04-20 14:43:28 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:53:11 UTC

Description Luigi Toscano 2018-04-20 14:43:28 UTC
Description of problem:
Two regressions compared to sahara-image-element for MapR 5.2 images:
- scala is not installed on RHEL/CentOS (the code is disabled with an exit 0) and it requires some changes anyway to install the last available version of scala without hardcoding 2.11.6;
- ntp/ntpdate, used during the cluster creation process, are not installed

Version-Release number of selected component (if applicable):
openstack-sahara-image-pack-8.0.1-0.20180320232516.d3322ef.el7ost

Steps to Reproduce:
sahara-image-pack --image sahara-rhel7-mapr-520.qcow2 mapr 5.2.0

Comment 5 Luigi Toscano 2018-04-30 15:27:55 UTC
The packages ntp and ntpdate, and scala (2.12.5) are installed correctly in the image.

Verified on:
openstack-sahara-image-pack-8.0.1-0.20180328233737.36531cb.el7ost
python-sahara-8.0.1-0.20180328233737.36531cb.el7ost.noarch
libguestfs-1.36.10-6.el7.x86_64

Comment 7 errata-xmlrpc 2018-06-27 13:52:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.