Bug 1570142 - CRI-O container runtime documentation for OpenShift
Summary: CRI-O container runtime documentation for OpenShift
Keywords:
Status: CLOSED DUPLICATE of bug 1564791
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 17:49 UTC by Sunil Choudhary
Modified: 2018-04-26 13:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 13:21:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sunil Choudhary 2018-04-20 17:49:16 UTC
The documentation for CRI-O container runtime is lacking in OpenShift Docs.

The only documentation for CRI-O we see is in OpenShift 3.9 Release Notes.

https://docs.openshift.com/container-platform/3.9/release_notes/ocp_3_9_release_notes.html#ocp-39-crio

There is no documentation on how to configure storage for CRI-O.
And more documentation on below points would make docs better.

- Default storage driver for CRI-O and which other storage driver is supported.

- Can container-storage-setup be used with CRI-O as it is used with docker daemon.

  For example when starting CRI-O service, can it use container-storage-setup 
  to setup Volume Group/Logical Volume storage based on configuration in 
  /etc/containers/storage.conf 

- How to migrate existing OpenShift cluster with docker container runtime to CRI-O container runtime.

  For example: OCP 3.7 with docker to OCP 3.9 with CRI-O

Comment 2 Kathryn Alexander 2018-04-26 13:21:17 UTC
Closing as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1564791.

*** This bug has been marked as a duplicate of bug 1564791 ***


Note You need to log in before you can comment on or make changes to this bug.