Bug 1570556 - sahara-image-pack/ambari: validation should accept all the HDP version enabled for the plugin
Summary: sahara-image-pack/ambari: validation should accept all the HDP version enable...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks: 1502848
TreeView+ depends on / blocked
 
Reported: 2018-04-23 08:42 UTC by Luigi Toscano
Modified: 2018-06-27 13:54 UTC (History)
6 users (show)

Fixed In Version: openstack-sahara-8.0.1-0.20180328233738.36531cb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:52:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack Storyboard 2001888 None None None 2018-04-23 08:42:47 UTC
OpenStack gerrit 527524 None master: NEW sahara: Adding Ambari missing versions (I88c2a553512a797099a4b2fbd9e9d204475e755b) 2018-04-24 16:08:09 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:54:15 UTC

Description Luigi Toscano 2018-04-23 08:42:47 UTC
Description of problem:
The new method AmbariPluginProvider.get_image_arguments passes the validation only when hadoop_version is '2.4'. But this prevents the creation of clusters based on HDP 2.3 (and any other version like HDP 2.5 once supported). 

Maybe the list of accepted versions should be taken from the plugin list, if it does not interfere with the version used for image generation (I think it's not, but...) (or the check could be dropped in the worst case). An hardcoded list is possible but it may be more complicated to maintain.


Version-Release number of selected component (if applicable):
openstack-sahara-8.0.1-0.20180328233737.36531cb.el7ost.noarch.rpm  

Steps to reproduce:
Run the scenario tests against HDP 2.3 with an image generated by 
sahara-image-pack --image <base_rhel75_image> ambari 2.4
and registered also with the 2.3 tag.

Comment 2 Luigi Toscano 2018-04-30 14:07:06 UTC
The patch landed and clusters based on HDP 2.3 can be spawned.

Comment 3 Luigi Toscano 2018-04-30 14:13:23 UTC
Uhm, not yet.

Comment 8 Luigi Toscano 2018-05-09 09:47:41 UTC
All versions of the plugin defined and enabled can be now used, including 2.3 - aka it is possible to spawn Ambari/HDP 2.3 clusters.

Verified with:
openstack-sahara-8.0.1-0.20180328233739.36531cb.el7ost

Comment 10 errata-xmlrpc 2018-06-27 13:52:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.